Firmware 3.1.3 required on some updated Apps

Discussion in 'Jailbreaks and iOS Hacks' started by ckong, Apr 4, 2010.

  1. ckong macrumors regular

    Nov 12, 2009
    Apologies if this has been posted before. I'm noticing some updated Apps are requiring firmware 3.1.3.

    AT&T Mark the Spot
    Sketches 2

    Unfortunately, I never checked the firmware requirements before letting iTunes update them. Since I'm on 3.1.2 I can't use the updated versions. The AT&T and Evernote apps are free, but I paid for Sketches 2 so I'm kind of disappointed. I have a backup of older AT&T app and have restored it. Unfortunately, I never backed up Sketches 2 so I'm out of luck there.

    I don't really blame the developers right off as the minimum 3.1.3 firmware setting is probably the default for the newer compilers compatible with the iPad (who might even be hard-coded that way).

    I jailbroke my phone so I broke the original license agreement and I guess I have to live with the limitation (for now). I'm hoping that the people that didn't jailbreak their phones start pressuring the developers to fix the default (if it's reset-able).

    I'm going to start backing up my Apps again, and be very careful to check each one that needs an update for the firmware required.
  2. macfan881 macrumors 68020

    Feb 22, 2006
    isnt there some app called Firmware faker that fakes out what firmware you have for JB?
  3. iphonegeek786 macrumors 6502


    Nov 18, 2009
    There is an app in cydia that fakes your firmware for 3.1.3. But I can't remember what its called.
  4. Applejuiced macrumors Westmere


    Apr 16, 2008
    At the iPhone hacks section.
  5. labman macrumors 604


    Jun 9, 2009
    Mich near Detroit
    I have 3.1.3 Faker

    I also have Mark the spot & Evernote both work just fine for me. I like the 3.1.3 faker I 1st heard about it though Musclenerd but I did uninstall it for a while and it doesn't uninstall clean. It caused several problems such as app crashes slow response no reported firmware in my about and other problems. once I reinstalled it everything was fine.
  6. ckong thread starter macrumors regular

    Nov 12, 2009
    Yeah. I knew about the firmware faker. Too many people had mixed results with the BigBoss one (and I really trust that developer). Some iPhones had to be completely restored. I depend on my phone too much to chance it so it's not an option for me at this time.
  7. dhlizard macrumors G4


    Mar 16, 2009
    The Jailbreak Community
  8. FSUSem1noles macrumors 68000


    Feb 23, 2006
    Ft. Lauderdale
    You can always upgrade to JB 3.1.3 if you want to use the apps that bad..

    I have a couple that require 3.1.3 also, but I just downgraded back to a JB 3.1.2 from an upgraded JB 3.1.2 > 3.1.3.. and I didn't feel like going through the whole JB process again just to get back to 3.1.3..
  9. mreddys10 macrumors regular

    Jul 29, 2008
    I was pretty disappointed when Dragon Dictaiton update required 3.1.3, but they have changed it back to 3.1 now. Most other apps might just follow that and change the requirement back down.
  10. scirica macrumors 68020


    May 13, 2008
    Dallas, TX
    Not because of app requirements, but since I wanted to re-jailbreak for performance reasons I went ahead and jb'd to 3.1.3. Does make life easier to co-exist with app store updates. If I wasn't have some issues with 3.1.2 I wouldn't have upgraded just because of app store updates however.
  11. justinwebb macrumors regular

    Aug 23, 2009
    i have the firmware spoofer on my phone for 3.1.3 never had one problem with it yet
  12. dhlizard macrumors G4


    Mar 16, 2009
    The Jailbreak Community
    Are you saying Dragon Dictation 1.3.1 no longer requires 3.1.3 ?

    Thanks for heads up on this, just updated it.
  13. Makaveli6103 macrumors 6502

    Jan 31, 2009
    Kansas City, MO
    is there anyway to downgrade to the Evernote that works with 3.1.2?
  14. dhlizard macrumors G4


    Mar 16, 2009
    The Jailbreak Community
    It should be in your trash if you didn't empty it.
  15. AlienSexGod macrumors member


    Mar 18, 2008
    Unsure if JB on 3.1.3 on 3GS works so this fixes apps that require OS 3.1.3

    Search in Cydia for Firmware 3.1.3 app, install it

    open Firmware 3.1.3 app select 3.1.3 & then select reboot

    note you must have 3.1.2 for this to work . No extra code to add in Cydia or anything ... works great...... iTunes this I am running 3.1.3!

Share This Page