Firmware EFI update just *&*^ my display up!

m3the01

macrumors member
Original poster
Jun 18, 2007
70
0
Just installed the firmware update, everything was fine before no yellow nothing.

Now i have lines running down my screen, horizontal. Only time i cant see them is on full brightness.

What to do, can i revert to the previous firmware.

I need my computer i program on it like 8 hours day,

Help!

Steven
 

squeeks

macrumors 68040
Jun 19, 2007
3,389
14
Florida
Just installed the firmware update, everything was fine before no yellow nothing.

Now i have lines running down my screen, horizontal. Only time i cant see them is on full brightness.

What to do, can i revert to the previous firmware.

I need my computer i program on it like 8 hours day,

Help!

Steven
yes we know, its been happening to random people, there are lots of threads about it, each has a link to a restortion CD download
 

kolax

macrumors G3
Mar 20, 2007
9,186
115
You did install it correctly by holding down the power button until you hear a beep?

Try resetting PRAM - hold down CMD+ALT+P+R during as grey screen appears at boot.
 

m3the01

macrumors member
Original poster
Jun 18, 2007
70
0
Sweet guys everything is kool now,

Yes i did install correctly,

I reset the pram as per instruction

Hold Command, Option , P and R keys all at the same time before the grey screen appears at boot.

So whats the deal, why did this happen?
 

squeeks

macrumors 68040
Jun 19, 2007
3,389
14
Florida
well, the pram holds all kinda settings and stuff, so when the firmware is updated it needs to clear the settings and stuff and start over...kinda like how you're supose to reset the bios on a PC after doing a bios update