Firmware issue need help! No HD!

Discussion in 'MacBook Pro' started by Gwardys, Jun 22, 2009.

  1. Gwardys macrumors member

    Joined:
    Apr 6, 2006
    #1
    I was one of those "complainers" about the sata problem because I purchased my 13'' MBP with an intel x25-m SSD.

    Excited to update I went through the process, like normal, except upon the restart of my computer the screen stayed gray until a gray blinking folder with a question mark popped up.

    I quickly looked up the apple support page for the problem, and attempted to solve it myself. I booted into the restore CD but I found no hard drive available. Next I reset the PRAM, but that also solved nothing.

    Afraid that my x25 was dead (weird since it was working two minutes earlier), I removed it from my MBP and put it into an external drive that the old HD was sitting in.

    The x25-m was instantly recognized on a different laptop in the enclosure. When I boot up my MBP with the old drive, I could see it under the disk utility application from the CD.

    I tried booting into the single user mode, but I can't seem to get my laptop into it. When I hit cmd+s it stays gray until the folder comes up.

    Someone! Anyone! I know that the geniuses at Apple will blame my hard drive, but I know it still works! Any ideas!?!'

    Edit: Holding down the option key brings up either nothing, or the restore CD only.
     
  2. alecgold macrumors 6502a

    alecgold

    Joined:
    Oct 11, 2007
    #2
    I had the same problems, but resetting pram did work for me.
    But I got a lot of other problems now. Everything that takes a bit of processingpower, it freezes for about 30sec. and then gets on.
    doing the firmware update again, doesn't seem possible, it says I've got the 1.7 firmware. Darn, this isn't funny.
     
  3. iLog.Genius macrumors 601

    iLog.Genius

    Joined:
    Feb 24, 2009
    Location:
    Toronto, Ontario
  4. vitaeergo macrumors newbie

    Joined:
    Jun 23, 2009
    #4
    Same Issue with a X25

    Same issue here with an Intel X25 80GB.

    Worked fine before the update. Now, it can't see it. My stock Hitachi 320GB boots up, but if I try the Intel, I can't. If I boot off of the DVD, disk utility and System Profiler do not see the Intel at all.

    Reset the PRAM per instructions (Tried four times), but doesn't seem to resolve anything.

    The Intel is a brand new drive and works if I put it into a Windows machine. Firmware for the Intel drive is up-to-date, according to Intel's utility. Not sure what else I can do.

    Anyone else with the problem?
     
  5. friareunuch macrumors member

    Joined:
    Jun 2, 2009
    #5
    yeah, i'm planning on buying one of the new Pros next week, along with the x25.

    any further word on this issue?

    thanks. i love you all.
     
  6. fehhkk macrumors 6502a

    fehhkk

    Joined:
    Jun 11, 2009
    Location:
    Chicago, IL
  7. Smoothie macrumors 6502

    Joined:
    Jun 23, 2007
    Location:
    California
    #7
    alecgold posted above that resetting the PRAM only allowed him to get it to boot, but his system is running intermittently. This seems to be a problem that some people are experiencing. It's also discussed on the Apple forum. It's hard to see a pattern to the problem. My stock 250 GB Hitachi drive seems to be working OK after the upgrade, but now I'm concerned about replacing the drive down the road.
     
  8. iain-nl macrumors newbie

    Joined:
    Jun 24, 2009
    #8
    I'm having this exact same problem. Tried resetting PRAM, tried reinstalling OSX (which took forever), no difference.

    I'm going on vacation tomorrow, will contact Apple next week, when I'm back.

    I also use the intel x25-m SSD btw.

    Anyone any luck so far?
     
  9. vitaeergo macrumors newbie

    Joined:
    Jun 23, 2009
    #9
    PRAM was a no-go

    I did try resetting the PRAM (several times), but the X25 was a no-go. Again, the MBP didn't even see the drive after the update. Windows machines were able to see the drive, however. Pre-update, MBP saw and used the drive just fine.

    I ended up shipping the drive back and will try a new replacement. If that doesn't work, then I'm not sure what to say as I see others have posted benchmarks with the X25. Will let you know once I get it in.

    Thx.
     
  10. iain-nl macrumors newbie

    Joined:
    Jun 24, 2009
    #10
    The funny thing is, I had time to do some benchmarks using xbench before the entire system went down.

    A friend of mine has a 1st gen unibody MBP with X25 and gets around 200MB/s random/sequential read speed. I got around 120MB/s.

    When I installed the updated, it didn't boot. I resetted PRAM and it did boot fine. Got 210MB/s in the benchmark. That is a proper speed!

    Then I rebooted and it was slow. When I ran xbench again a few times it had no consistency whatsoever, sometimes getting 3MB/s, sometimes 200. Mostly slow though.

    After some more resetting and reinstalling this remained the case. Then I repaired disk permissions but now it wouldn't boot AT ALL from the SSD. Booted with the setup dvd, performed "Repair disk" with Disk Utility, but this is still running. Takes forever.

    Edit: Repair disk didn't work
     
  11. friareunuch macrumors member

    Joined:
    Jun 2, 2009
    #11
    This may seem a stupid question, but if I were to buy a computer online today, would it come with the SATA firmware upgrade?

    Could I avoid this problem by just not doing the firmware update, in the hopes that Apple will fix it in the next couple weeks?
     

Share This Page