Firmware Restoration on Mid-2010 Macbook pro 13 inch?

Discussion in 'MacBook Pro' started by colldo256, Nov 28, 2012.

  1. colldo256 macrumors newbie

    Joined:
    Nov 28, 2012
    #1
    Hi, I have a mid 2010 13 inch macbook pro, that I bought broken off of eBay in hope of fixing it and giving it to my little brother to do school work on. Since I got it so cheap, I figured out it was worth the time and hassle to fix. All the hardware appears to be working, except that the actual operating system doesn't boot up! I figured this was a software problem. I have tried multiple hard drives and the same thing happens. I have even tried resetting the PRAM and to no avail. What I want to know, is which Firmware Restoration CD do I have to download for it to restore the firmware on this particular machine?

    To clarify the issue I am having, when the Mac boots up to the grey Apple logo, the little gear spins for about 5-10 seconds, then freezes and it won't boot up.

    Thanks and your help will be greatly appreciated!
     
  2. bjm2660, Nov 28, 2012
    Last edited: Nov 28, 2012

    bjm2660 macrumors 6502

    Joined:
    Jun 7, 2011
    Location:
    Virginia
    #2
    How do you know all the hardware is fine if you can't boot up? Just sayin'
     
  3. colldo256 thread starter macrumors newbie

    Joined:
    Nov 28, 2012
    #3
    Well, because I have tried multiple hard drives that work fine on my other Mac, but not on this one. I have even tried to boot off of a SSD drive. and when the Apple logo is loading for 5-10 seconds, it freezes and doesn't do anything. I am unable to do anything beyond the Apple logo regardless if I change hard drives.
     
  4. T5BRICK macrumors 604

    T5BRICK

    Joined:
    Aug 3, 2006
    Location:
    Oregon
    #4
    I'd suggest running Apple hardware test. Do you have the restore DVDs for the computer?

    Also, I'm not sure what you're asking about when you mention the firmware. Do you just mean the OS?

    The OP said he tried more than one hard drive.

    ----------

    It's possible that the OS on the other drives just didn't boot because of a driver conflict(this is pretty unlikely).

    Maybe the SATA cable for the HDD is shot?
     
  5. colldo256 thread starter macrumors newbie

    Joined:
    Nov 28, 2012
    #5
    Yes, Im going to run a hardware test and see if it is indeed a hardware problem.
     
  6. bjm2660 macrumors 6502

    Joined:
    Jun 7, 2011
    Location:
    Virginia
    #6
    We had dual hard drives in a Mac Mini at my church. The operating system was on one. There was an intermittent freezing/crashing problem. We ran tests. We brought it in for service several times. The logic board was replaced; the ram was replaced. The problem kept resurfacing. Eventually, we installed the OS on the other HD. There hasn't been a problem in more than a year.

    Sometimes a hard drive can be intermittently failing. It's like taking the car to the mechanics, but it won't exhibit the same behavior when it's being scrutinized!

    Who knows? Good luck. Report back.
     
  7. colldo256 thread starter macrumors newbie

    Joined:
    Nov 28, 2012
    #7
    Unfortunately, I do not have the original dvds for the specific model of the computer. My only option right now is to try to do a firmware restoration, but I am not sure if its 1.9, or 1.8 that goes on a mid 2010 13 MacBook Pro.

    I would like to point out that I am certain it is not a hard drive problem, as the computer reads there is an OS on the system (or else there would be a flashing folder with a question mark), however, the system doesn't want to get past the little loading gear and Apple logo.
     
  8. ggn1971 macrumors newbie

    Joined:
    Sep 27, 2012
    #8
    Hi,
    have you tried to change the HDD cable for a good one? IMHO, the symptoms you describe indicate a bad cable...
     
  9. colldo256 thread starter macrumors newbie

    Joined:
    Nov 28, 2012
    #9
    Does anyone know what the firmware restoration cd version is? I just want to try out my "free" options before I have to go out and spend money on the cable. Thank you.
     
  10. chrfr macrumors 603

    Joined:
    Jul 11, 2009
    #10
    It's to backdate the firmware in the event of the firmware update failing. That scenario is extremely rare, so it's unlikely to be the problem here.
     
  11. colldo256, Nov 29, 2012
    Last edited: Nov 29, 2012

    colldo256 thread starter macrumors newbie

    Joined:
    Nov 28, 2012
    #11
    I'm almost certain it can be a firmware issue, because I created a little mountain lion partition to run it off my USB drive, but I still get the same problem. I actually don't even have a hard drive connected to it right now, it's only trying to run off of a USB drive, so it can't be the cable.

    @ chrfr

    I meant which (1.8,1.9,,1.7,etc) is the firmware restore cd I have to download, not what. I understand what the firmware is and how it can impact system hardware, similarly to BIOS in PCs.
     

Share This Page