Firmware update=blank screen

Discussion in 'MacBook' started by Dobiewonkanobie, Apr 27, 2008.

  1. Dobiewonkanobie macrumors regular

    Joined:
    Nov 16, 2007
    #1
    Here's the story:
    My girlfriend's MB was apparently running really slow. Things weren't running right, and at one point she got the Pinwheel-O-Death. So she thought maybe she needed to load the latest firmware update that came out last. When it restarted she got white screen and then the blinking "?" folder. Now when starts it up she gets the white screen and, after several minutes, the blinking "?" folder again.

    She got her MB back in October about a month before Leopard came out. It was the lower end version at that time. She was since upgraded it to Leopard.

    Oh, and it had half of my old RAM. (I accidently left the other behind when I was home last)

    I looked around the forums but didn't find anything directly relating to the firmware update, just stuff about bad HD's.
    She's gonna take it the store as soon as she can. We're on opposite coasts so I'm doing what I can from here in the meantime.
    Any help or feedback is appreciated
     
  2. myuserid08 macrumors 6502

    Joined:
    Mar 15, 2008
    #2
    If it was running slow before the firmware update its probably just a coincidence that the drive failed after the firmware update.
    I wouldn't take it to apple, if you can use a screwdriver you can replace the drive yourself (unless its still under warranty).
     
  3. Dobiewonkanobie thread starter macrumors regular

    Joined:
    Nov 16, 2007
    #3
    It was the hard drive. She took to the store and they checked it out. It was replaced under Applecare warranty. Hopefully this should teach her to back things up like I kept telling her.
     

Share This Page