Firmware Update Killed LaCie DVD Burner - Am I Outta Luck?

Discussion in 'Mac Accessories' started by Makosuke, Mar 3, 2007.

  1. Makosuke macrumors 603

    Aug 15, 2001
    The Cool Part of CA, USA
    Somebody where I work bought one of those USB2 "Porsche" DVD burners from LaCie, and I was just trying to get it set up and working.

    The discs it came with were Windows-only, so I went to their site to see what I could download. There was a firmware update, some LightScribe software, etc.

    So I download everything and start installing. Everything's fine until I do the firmware update... and the underlying task it launches crashes immediately. The GUI app grinds away for a bit and then tells me that my firmware is updated. Ok... except it's not.

    In fact, the drive is basically a brick now--as soon as I power it on (connected to anything or not) the indicator light comes on and stays on, and it won't so much as twitch--even the eject button won't open the tray. System Profiler sees it under the USB tree, but doesn't know what kind of device it is and it doesn't even show up under Disc Burning. Re-running the LaCie firmware updater doesn't recognize it as a DVD drive.

    Tried all the obvious--restart, turn the drive off and let it sit, reinstall everything--no luck. Definitely screwy firmware. I've filed a support ticket, but it'll be next week before I get a response, and I'm wondering if there are any firmware restoration tricks I'm not thinking of. Were it a DIY thing I'd take it out of the case and try a Windows machine to reflash it, but I can't even figure out how to get the case open without destroying it, and I sure don't want to void my warranty now...

    Man, this is not my week for hardware. I should just stop messing with stuff before I break even more.
  2. eluk macrumors 6502a


    Dec 14, 2006
    East London, UK
    I'd try connecting it to a Windows box and see if it was recognised. If so you may be able to update the firmware from there.
  3. mikes63737 macrumors 65816

    Jul 26, 2005
    I have a Porsche design HD from LaCie and it's really easy to open. If it's the same, the top isn't really metal, it's plastic. You can put a flat-headed screwdriver along the sides, and you can pry up the middle part.

    This is scary... I was just about to buy one of those drives.
  4. Makosuke thread starter macrumors 603

    Aug 15, 2001
    The Cool Part of CA, USA
    Thanks for the suggestion; I tried feeding it to XP under Parallels to see what it saw. It claimed to recognize both the bridge and the drive itself--showed up as the correct model optical drive and everything--but I still couldn't even get the tray to open, and all three LaCie firmware updaters didn't recognize it as updateable. Maybe I'm missing a step in here, but I'm not terribly optimistic...

    And thanks for the tip on the case, mikes63737; it kinda looks like the top will lift up, but with no obvious spots to pry I don't really want to go jamming screwdrivers into it since it's still under warranty. I'll wait and see what their tech support says on Monday before I get drastic.

    I admit, maybe I just made a mistake somewhere, but I've updated the firmware on several firewire drives in the past and I certainly don't see anything I could have done different...

Share This Page