[First-Gen iPhone, 2.0] Mail app crashing at launch

Discussion in 'iPhone Tips, Help and Troubleshooting' started by omgitscro, Jul 12, 2008.

  1. omgitscro macrumors 6502a

    omgitscro

    Joined:
    Jul 12, 2008
    #1
    My Mail.app is crashing whenever I launch it. I can send E-Mails if I send from Photo or the Camera, but actually opening the app doesn't work. I cannot sync my mail accounts from iTunes, because an error pops up alerting me that Mail.app from my iPhone canceled the sync. I am using the 1,2 version of 2.0 on my first-gen 8GB iPhone. I am currently downloading the 1,1 version. I believe that mail.app crashing has to do with my restore- I would restore without syncing with my old backup, except I don't think my Super Monkey Ball save would sync back if it was considered a new iPhone. What do I do to fix my Mail.app?
     
  2. z062007 macrumors member

    z062007

    Joined:
    Mar 28, 2008
    Location:
    Detroit, Michigan
    #2
    did you install the leaked copy of the firmware before Apple officially released it? I am wondering if that might be causing the problem
     
  3. iBookG4user macrumors 604

    iBookG4user

    Joined:
    Jun 27, 2006
    Location:
    Seattle, WA
    #3
    I'm having the same problem with my first gen iPhone. I did not install the hacked firmware, I installed the one apple released using iTunes.
     
  4. omgitscro thread starter macrumors 6502a

    omgitscro

    Joined:
    Jul 12, 2008
    #4
    I updated to 1,1 from 1,2.

    Mail.app launches and gets my mail like it should now.

    However, iTunes still cannot sync if I have 'sync mail accounts' enabled. I have it off for the time being.
     
  5. ifone04 macrumors newbie

    Joined:
    Jul 13, 2008
    #5
    I also installed 2.0 from iTunes and my mail app crashes every time i try to open it, but I can send photos via camera. Does anyone know how to resolve this issue?!?!
     
  6. cubbie5150 macrumors 6502a

    cubbie5150

    Joined:
    Mar 4, 2007
    #6
    I'm having the same issue since finally updating from jailbroken 1.14 last night... Any help please?
     
  7. brethansen macrumors newbie

    Joined:
    Oct 20, 2007
    #7
    I resolved this issue by doing a restore

    Doing a restore fixed this, but then I had problems with some of the new apps from Apple not working. I had to reinstall them.
     
  8. cubbie5150 macrumors 6502a

    cubbie5150

    Joined:
    Mar 4, 2007
    #8
    Ugh... I was afraid that would be the "fix." I guess I'll have to re-enter all my settings fater restoring tonight. Can't believe how dependent I am on mobile email now.
     
  9. ucfgrad93 macrumors P6

    ucfgrad93

    Joined:
    Aug 17, 2007
    Location:
    Colorado
    #9
    I upgraded my 1G iPhone last Friday and do not have this problem.
     
  10. drian macrumors newbie

    Joined:
    Jul 22, 2008
    #10
    Mail Fix

    This fix comes adapted from http://www.ben.geek.nz/fixing-iphone-mail-crashes-20-firmware/
    The problem is the user privileges to the directory that your mail is stored in is owned by user “root” and under 2.0 Mail requires ownership by user “mobile”. The following procedure fixes this.
    1. Download MobileTerminal from Cydia if you haven’t already done so (it’s in the Featured Packages section).
    2. Open MobileTerminal – this looks like the Terminal on a Mac or the Command Prompt on a PC. It’s very small so you have to type very carefully. If you’re not familiar with UNIX commands type very very carefully and pay attention to Capital Letters. The Commands you will enter are case sensitive. Type everything within the quotes (but not the quotes).
    3. Enter “su” press return
    4. You will be prompted for a password, enter “alpine” press return (if you’ve already changed the root password enter your new password).
    5. Enter “cd /var/mobile/Library” press return (Note the capital L in Library)
    6. Enter “chown -R mobile:mobile /var/mobile/Library/Mail” press enter (note the capital letters again)
    All fixed, you’re done, exit MobileTerminal and the Mail app should work :cool:
     
  11. dudupst macrumors newbie

    Joined:
    Jul 24, 2008
    #11
    Worked for me

    THX!
     
  12. firdouss macrumors newbie

    Joined:
    Jul 25, 2008
    #12
    Thanks a lot for the tips! Works for me like a charm!
     

Share This Page