First-gen iphone maps won't work!

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Gock, Aug 29, 2008.

  1. Gock macrumors newbie

    Joined:
    Aug 11, 2008
    #1
    I have the first gen iphone and after the 2.0.1 update, my maps won't work at all now! I bring up the maps, and the maps gui comes up but without any actual maps. It stays there for about three seconds, then closes and goes back to the home menu.

    I've tried restarting the phone, clearing the network settings, and restoring the phone through itunes. No luck! It worked fine before 2.0.1

    I called Apple on the issue and they said if a restore didn't take care of it, then it must be a hardware problem and I would need to send it in. Problem is my phone is out of warranty and they said it would cost $199 to repair it! I might as well get a new one!

    I updated to the 2.0.2 update when it came out but it didn't fix my problem :(

    Anybody else having this problem or found a fix? I still think it's a firmware bug seeing as how it worked up until I updated to 2.0.1.
     
  2. claya macrumors newbie

    Joined:
    Sep 5, 2008
    #2
    Same thing happens with my iphone 1st gen. Everything else works fine. Maps app starts hangs for a minute then goes back to the icons screen. Other applications can locate my position still. I was downloading some apps and the next thing I know my phone crashed then Maps quit working. :(

    There has to be more people having this same problem!
     
  3. tungstentim macrumors regular

    tungstentim

    Joined:
    Dec 1, 2007
    #3
    I had the same problem. It's a known issue that will hopefully get fixed soonish.

    If you change your geographical location ie go on a road trip you should find that google maps will work some of the time. It did for me. Though at home it can't always find me.

    This is with either a 2g iphone on 2.02 or a 3g iphone on 2.02.

    Tim
     
  4. neesh0 macrumors 6502a

    neesh0

    Joined:
    Sep 6, 2008
    Location:
    Toronto, Ontario
    #4
    If your iphone is jailbroken, get bossprefs from cydia, go to more options, then press Fix permissions, this should help.
     
  5. claya macrumors newbie

    Joined:
    Sep 5, 2008
    #5
    Fixed it! Finally...

    :) Settings>General>Reset>Reset All Settings...

    It didn't kill any data like contacts...but had to re-add my exchange information, and any passwords for routers...

    This is the thing that fixed my Maps... on my 1st gen iphone with 2.0.2.

    My phone is NOT jailbroken.
     
  6. Gock thread starter macrumors newbie

    Joined:
    Aug 11, 2008
    #6
    Yesss! That "reset all settings" option fixed me too. I don't know why I didn't try that... maybe because I was afraid it'd delete something important. At any rate, sweetness! Hopefully the 2.1 firmware update this coming Friday doesn't cause any new problems.
     

Share This Page