First issue with my new 21.5" iMac

Discussion in 'iMac' started by SidZer0, Mar 7, 2013.

  1. SidZer0, Mar 7, 2013
    Last edited: Mar 7, 2013

    SidZer0 macrumors newbie

    Joined:
    Sep 6, 2012
    #1
    So I'm running a dual monitor setup with my new iMac, the 2nd monitor is a fairly new LG E2241 connected with a Mini DVI to HDMI cable via the Thunderbolt port. Here's the issue, everytime I go to "wake up" the system after a prolonged sleep period the iMac starts starts up fine but the 2nd monitor remains in sleep mode as if it wasn't even connected. The iMac actually reverts back to a single screen setup too. The only way to get it to wake up its to disconnect and reconnect from the TB port. I could turn off the sleep feature but I really don't think that's a good idea, so my work around is turning off the iMac between long periods of use.

    Is anyone else having this issue with their dual monitor setups? If so were you able to fix it or know if this issue will be resolved with an update or patch?

    FYI, I never had this problem with my mid 2010 MBP connected to this same monitor for over a year. So I'm suspecting this is a TB issue.

    Thanks in advance.
     
  2. justperry macrumors 604

    justperry

    Joined:
    Aug 10, 2007
    Location:
    In the core of a black hole.
    #2
    Are you on 10.8.2, if so that might be the problem, plenty of sleep issues, if so try this, set the Mac to never sleep and manually put it to sleep, if this helps you can set it back but need to set the standby and autopoweroff to 0 in pmset

    to do so enter in terminal:

    sudo pmset autopoweroff 0
    enter
    enter password
    sudo pmset standby 0
    enter
    If asked for password enter it again.

    But, before you do first enter pmset -g, it will show you the current values, after you do the above commands enter pmset -g again and compare with first ones.
     
  3. SidZer0, Mar 7, 2013
    Last edited: Mar 7, 2013

    SidZer0 thread starter macrumors newbie

    Joined:
    Sep 6, 2012
    #3
    So what exactly will those commands change if the iMac is already in "never sleep" mode? Sorry, I'm not that proficient with terminal.
     
  4. justperry macrumors 604

    justperry

    Joined:
    Aug 10, 2007
    Location:
    In the core of a black hole.
    #4
    Power Management settings, if it does not work you can easily revert by changing 0 to one or 1 to zero, no damage done.
     
  5. Macman45 macrumors demi-god

    Macman45

    Joined:
    Jul 29, 2011
    Location:
    Somewhere Back In The Long Ago
    #5
    I guess this has been covered extensively, but I've now killed hibernation on 3 Macs including my own 27" and it fixes the issue. Apple know about it, and are working on a fix...See this thread for details:

    http://forums.macrumors.com/showthread.php?t=1529750
     
  6. SidZer0 thread starter macrumors newbie

    Joined:
    Sep 6, 2012
    #6
    Should I run those settings with the display sleep enabled or disabled?
     
  7. justperry macrumors 604

    justperry

    Joined:
    Aug 10, 2007
    Location:
    In the core of a black hole.
    #7
    These are my settings and since I set them to these the Mini does not have sleep problems.
    Also, read Macman45's link, I think I got this from him or his link. before.

    standby 0
    powerbutton 1
    womp 0
    autorestart 1
    hibernatefile /var/vm/sleepimage
    networkoversleep 0
    disksleep 10
    sleep 0
    autopoweroffdelay 14400
    hibernatemode 0
    autopoweroff 0
    ttyskeepawake 1
    displaysleep 10 (display sleep prevented by )
    standbydelay 4200
     
  8. SidZer0 thread starter macrumors newbie

    Joined:
    Sep 6, 2012
    #8
    These are my settings now and it has seemed to have worked. :D

    standby 0
    powerbutton 1
    womp 1
    halfdim 1
    hibernatefile /var/vm/sleepimage
    autorestart 0
    networkoversleep 0
    disksleep 10
    sleep 120
    autopoweroffdelay 14400
    hibernatemode 3
    autopoweroff 0
    ttyskeepawake 1
    displaysleep 30
    standbydelay 4200

    Thank you.
     

Share This Page