First Mac... 1 question

Discussion in 'MacBook Pro' started by mets1125, Dec 9, 2008.

  1. mets1125 macrumors regular

    Joined:
    Sep 4, 2007
    Location:
    Queens, NY
    #1
    I finally bought a Macbook Pro 2.4(uni) first Mac. Everything was going really well the past 2 days except this morning when I go to a website sometimes the bar will load up 1/2 way and stop I have to press on the bar (whatever loaded stops) then I press enter and the page takes 1 sec to load. Why does this happen to me on every other pages? Thanks :confused:
     
  2. amac4me macrumors 65816

    amac4me

    Joined:
    Apr 26, 2005
    #2
    Perhaps an Internet connection issue. Do any other computers on your network experience this problem?
     
  3. OrangeSVTguy macrumors 601

    OrangeSVTguy

    Joined:
    Sep 16, 2007
    Location:
    Northeastern Ohio
    #3
    I take it you are using Safari? I really never liked that web browser because it always seemed slow and sluggish to me, not to mention that it used to crash more often too. Try installing all updates. Download Firefox as that's what I always use and I don't have any problems with it.
     
  4. themoonisdown09 macrumors 601

    themoonisdown09

    Joined:
    Nov 19, 2007
    Location:
    Georgia, USA
    #5
    I've always used Safari and I never have problems with it crashing. I guess it all depends on what websites you go to.

    I would think your problem has something to do with the network connection.
     
  5. Sky Blue Guest

    Sky Blue

    Joined:
    Jan 8, 2005
    #6
    You'll find FireFox is a lot slower than Safari. Try empty your cache.
     
  6. rychencop macrumors 65816

    rychencop

    Joined:
    Aug 17, 2007
    Location:
    http://www.northaugusta.net/
    #7
    Slower doing what exactly?
     
  7. themoonisdown09 macrumors 601

    themoonisdown09

    Joined:
    Nov 19, 2007
    Location:
    Georgia, USA
    #8
    It seems to be different for everyone. It's mostly just personal preference.

    By the way, rychencop, I love your avatar.
     
  8. rychencop macrumors 65816

    rychencop

    Joined:
    Aug 17, 2007
    Location:
    http://www.northaugusta.net/
    #9
    yeah...i have used both and speed wise they are pretty equal. i like the ease of use in Firefox, so that's my preference.

    :D
     
  9. drichards macrumors 6502a

    drichards

    Joined:
    Nov 30, 2008
    #10
    Firefox's rendering engine is just plain slower than Safari's webkit. It also often takes longer for Firefox to load on macs, especially if you have enabled check for updates at launch.

    I use Safari, that's my preference. Everyone is different, and alot of switchers will feel more comfortable initially with Firefox, because they've used it on pc.
     
  10. cg165 macrumors regular

    Joined:
    Jun 24, 2008
    #11
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 2_2 like Mac OS X; en-us) AppleWebKit/525.18.1 (KHTML, like Gecko) Version/3.1.1 Mobile/5G77 Safari/525.20)

    Actually this has been happening to me too! I thought it was my Internet connection, but I guess not. It will show the progress bar as half loaded and I'll have to refresh to get it to go which sometimes doesn't work either.

    I've actually tried turning airport off, waiting a few seconds then turn it back on again and it seems to work great for that session at least no matter what page I go to. I'm hoping that gets fixed. It doesn't do this all the time either.
     
  11. mets1125 thread starter macrumors regular

    Joined:
    Sep 4, 2007
    Location:
    Queens, NY
    #12
    thanks... I downloaded firefox and I do not have any problems with it. My problem is with safari. I called applecare and was on the phone with them for 1.5 hrs. The final thing he told me to try was to reinstall OSX. I still have not done it but I will get to it eventually.
     
  12. mets1125 thread starter macrumors regular

    Joined:
    Sep 4, 2007
    Location:
    Queens, NY
    #13

    Were you able to get the problem fixed? Do you know what the problem is?
    I cant stand how the browser just hangs, and it doesnt always happen just like every other page. Please keep me updated. Thanks
     

Share This Page