First mouse click not registering?

Discussion in 'MacBook' started by Mal, Jun 1, 2010.

  1. Mal macrumors 603

    Mal

    Joined:
    Jan 6, 2002
    Location:
    Orlando
    #1
    I'm having a weird issue with my Aluminum MacBook (2008). This occurs mostly in Safari, though I don't use most other applications enough to notice if it's occurring elsewhere. When I click using the trackpad (I usually tap, but I've noticed it happens even with a physical click sometimes), the link that I was clicking on will stay the active color, and the mouse will keep the pointing finger shape instead of reverting back to the arrow, but the click doesn't actually seem to register. I have to go back and click a second time, and if I click somewhere else, it will register that one fine, so I know it's not just being slow. Has anyone else experienced anything like this?

    jW
     
  2. henrock macrumors newbie

    Joined:
    Jan 31, 2011
    #2
    I have the exact same problem. EXTREMELY annoying, I don't know what to do. Random mouse clicks just don't seem to register. It happens in all applications and with both the trackpad and the usb and bluetooth mice I have tried. I have also reupdated my system with the 10.6.6 combo updater, booted from the install dvd to check and repair my startup disk, quit processes that might affect mouse behavior (wacom drivers, usb overdrive). Nothing helps. I'm not sure exactly when the problem first appeared or what I have done/installed since then.

    Have you solved the problem Mal, or does anyone have a clue what's going on?!
     
  3. Mal thread starter macrumors 603

    Mal

    Joined:
    Jan 6, 2002
    Location:
    Orlando
    #3
    Wow, this has been a while.

    For me, the problem was caused by BetterTouchTool or JiTouch (never had them both installed at the same time, but the problem occurred with either). Once I uninstalled that, I had no more problems.

    jW
     

Share This Page