First odd iMac behavior

Discussion in 'Mac Accessories' started by TheBrazilianGuy, Jan 19, 2007.

  1. TheBrazilianGuy macrumors regular

    Jul 26, 2006
    Ok, I just arrived at home and booted my wife's iMac G5, where
    I have an account.

    Everything goes fine until I access my account (or any account)
    and notice that the wired keyboard does not work. For a few seconds
    I can see a new icon at the dock showing a circle and a key on it
    before it disappears. It looks a sort of locker but there is no
    indication of any restrictive access.

    This is a first for me. Could someone hint what could be happening ?

    Thanks !
  2. TheBrazilianGuy thread starter macrumors regular

    Jul 26, 2006
    After a small digging, I noticed that every user did not have permission
    to write on the drive. I fixed the permissions and now the group is "system",
    which does not allow to use the keyboard. It seems that
    I can not alter anything on any account ! (ie, no input is allowed)
  3. TheBrazilianGuy thread starter macrumors regular

    Jul 26, 2006
    I think I found the problem but still I need assistance.
    After Verifying the disk, here is the report :

    Verifying HFS Plus Volume
    Verifying Extends Overflow file
    Verifying catalog file
    Verifying multi-linked files
    Verifying catalog hierarchy
    Verifying extended attributes file
    Verifying volume bitmap
    Verifying volume info



    What a **** is this ?
  4. TheBrazilianGuy thread starter macrumors regular

    Jul 26, 2006
    Well...I repaired the disk, the reboot is much faster
    but the problem remains.

    I will check the SMART logfile...maybe it IS a hardware failure
    after all.

  5. Makosuke macrumors 603

    Aug 15, 2001
    The Cool Part of CA, USA
    What I think you're describing doesn't sound like a drive problem, although it might be--the fact that it boots ok means that the drive is probably alright--the minor volume header issue does just happen sometimes. If it were stallig or panicking randomly, that might be a failing drive, but if you just can't seem to get the keyboard to do anything, that sounds like a different issue.

    First thing I'd try is moving where the keyboard is plugged in in the back, to check if there's a bad USB port.

    I'm guessing from your description that you can use the mouse, so something's working, but maybe try plugging it in separately from the keyboard, if it isn't already.

    If you are able to access the System Preferences, try going to the Accounts section and creating a new account, then see if that account displays the problem--that'll narrow it down somewhat.

    It could also be that something like StickyKeys got turned on in the Universal Access Preference Pane--you might have a look in there and make sure everything is off.
  6. maxrobertson macrumors 6502a

    Jun 15, 2006
    maybe if you tried plugging it in to a different USB port? Or check if any settings are wrong in System preferences.
  7. TheBrazilianGuy thread starter macrumors regular

    Jul 26, 2006
    Thank you, thank you very much for the input.

    I was/am in despair.

    First of all, my HD does not indicate any failure.
    I had tried all USB ports before posting here and the keyboard
    does look to be working (at least the shortcuts and eject CD button).
    As you well noticed, my mouse is ok which indicates that its cable is
    not ruined.

    I checked the StickyKeys and they are not on. Good idea though.

    Now, regarding the creation a new user, how can I do that if
    I can not use the keyboard ? There is no way to enter any
    character/symbol there (I tried).

    The only thing I could do was to hook up my external drive and
    backup everything.

    Oh, last thing...if I log in user A and check its HD permissions,
    it says that user A can read and write. When I go to account B,
    HD properties indicates that user A (!) is the only one who can
    read/write. After fixing this, the keyboard is still off and if I
    switch back to user A, now its permissions are gone (and user B is
    the new owner).

    That's puzzling !!!

  8. TheBrazilianGuy thread starter macrumors regular

    Jul 26, 2006

    That's hard to believe.

    Even though the mouse was working (it was hooked up to the
    keyboard), I put it in a different port and now the keyboard is
    functioning again.

    Was this a hiccup ?

    What a relief !!!

    Thanks a million for your help !
  9. Makosuke macrumors 603

    Aug 15, 2001
    The Cool Part of CA, USA
    It sounds like there's something wrong with the mouse, or (possibly) the port on the keyboard. The mouse could well function but screw up other things on the chain (the keyboard in this case). Alternately, if there's something wrong with the keyboard USB ports, having something plugged into them might be the cause of the problems.

    You won't really know unless you can get your hands on another mouse to experiment.

    If the combination of the mouse and keyboard was drawing too much power it might act a little like that, but I've never seen that happen and you should have gotten a warning anyway.

Share This Page