First problem already for 2011 Macbook Pro 17" (2.2Ghz Quad Core)

Discussion in 'MacBook Pro' started by iPadThai, Feb 27, 2011.

  1. iPadThai, Feb 27, 2011
    Last edited by a moderator: Feb 27, 2011

    iPadThai macrumors 6502a

    Joined:
    Apr 25, 2010
    #1
    I am noticing a strange behavior with my new 17" 2011 macbook pro 2.2 i7:

    The wifi connection drops out - I mean I'm connected to an access point (wireless N) - but after a while when I don't use the laptop (letting it idle), I come back and the wireless connection is gone. I have to turn airport OFF then back ON to resume the connection. Once it actually "lost" my access point password as well.

    I don't have the computer sleep automatically (turned off in power savings preference) nor do I have the laptop shut off hard disk whenever it can. I'm having a feeling though when the LCD screen goes into sleep it turns off my wifi but I tried setting the LCD to shut off every minute but connection still remains..it's only when I come back after 15-20 minutes do I see this occur.

    Anyone else have this issue?:confused::confused:

    Alright, I tested it this time again - I left the machine ON overnight. I come back now and voila, the wifi connection is GONE! IN fact, when I click the airport icon, it shows NO NETWORK DETECTED. I have to turn airport OFF then back ON for a connection to become active again.

    This is definitely an issue - anyone experience the same thing?
     
  2. timbloom macrumors 6502a

    timbloom

    Joined:
    Jan 19, 2002
    #2
    Before doing anything drastic I would update the firmware on your wireless base station. Cleaning out your stored wireless passwords in /Applications/Utilities/Keychain Access.app and deleting the "remembered" wifi networks from the airport tab in network preferences will be a good start too.
    If none of this helps I would call AppleCare support and get a case started.
    While it's a possibility that the network card in the machine is faulty it's also very likely, since the machine is so new, that there is a bug in the wireless driver and that apple will issue an update soon.

    I had also once received a 2wire wireless gateway that would exhibit behavior like this only on my MacBook pro, and never could get it resolved and had to return the 2wire box.
     
  3. iPadThai thread starter macrumors 6502a

    Joined:
    Apr 25, 2010
    #3
    I think your solution may of solved the problem! I removed my keychain wireless passwords - in fact, I did IMPORT those from my old C2D 17" - now it seems to not disconnect...I will try again letting the machine idle for a few hours to be certain!

    Thanks!!
     
  4. crunkcrumpet macrumors member

    Joined:
    Apr 28, 2005
    #4
    My machine isn't a 2011 or 17" model, but it's still a Macbook Pro, I have a late 2009 13" which does the exact same thing..there's seems to be no rhyme or reason why it does it. I've tried all sorts and nothing has resolved my issues.
     
  5. jeffy.dee-lux macrumors 6502a

    Joined:
    Nov 19, 2003
    Location:
    montreal
    #5
    I just got a new 15" yesterday and I've already had my first Kernel panic! It was giving me a hard time while trying to restore from my time machine backup of my old computer using migration assistant. The thought of going back to the store definitely came to mind.
     
  6. Buck987, Feb 27, 2011
    Last edited: Feb 27, 2011

    Buck987 macrumors 6502a

    Joined:
    Jan 16, 2010
    #6
    I have a similar problem with my 2010 macbook pro when I first got it. All other devices would work well in my house, including an iPad, but the MBP kept dropping the connection.

    Tried firmware and all other tricks, visits to genius bar, calls to tech support...nothing helped.

    In the end I had to change routers. Problem solved.
     
  7. iPadThai thread starter macrumors 6502a

    Joined:
    Apr 25, 2010
    #7
    The connection seems to be fine now - I don't know what to say about this but it doesn't drop. I'll put it in idle mode tonight until next morning to make sure it won't do the same thing. The removal of the keychain wireless passwords did seem to fix this but an over night test would prove it. The router is fine - everything else include my 15" and 17" c2d macbooks connect and not disconnect. I don't think it's the router but could very well be with the new 2011 airport hardware?

    I just encountered a full lock up. NO RESPONSE from the entire OS while I was trying to encode a 1080 HD video in iMovie. I had to hard shutdown the laptop. I'll have some numbers in a an hour - trying to encode with and without the Turbo 264HD dongle...
     
  8. Viper2005 macrumors 6502

    Viper2005

    Joined:
    Dec 2, 2007
    Location:
    Canada
    #8
    I have had this problem with my Late 08 MBP. It seems to dislike certain Belkin Routers with encryption turned on. Funnily enough once I turned off the encryption the connection would stay solid. But since thats not good for security, I replaced the Belkin with an Airport base station (with wpa) and its been fine ever since.
     
  9. iPadThai thread starter macrumors 6502a

    Joined:
    Apr 25, 2010
    #9
    Right when I thought things were normal again - the wifi connection just DROPPED OFF WHILE THE COMPUTER WASN'T IDLE! I may look into another router - but the 2009 c2d 17" and another 15" I have both don't have this issue...
     
  10. Macloven macrumors regular

    Macloven

    Joined:
    Aug 25, 2008
    #10
    I had a similar situation with my daughters mb pro in our house. No problems connecting with 3 other mb's but hers always inconsistent. 2wire router replaced due to changing isp and no problems since. Must be hardware differences from one logic board to the next.

    Hope you get it sorted out.

    mg
     
  11. biznix macrumors newbie

    Joined:
    Mar 2, 2011
    #11
    I got the same problem.

    I got my new mbp 2011 15" from Apple store last Sunday and have returned the computer yesterday. The possible reason is that the new wifi hardware on the new mbp may not work with some router. I saw many posts on apple support forum with this issue. If you call apple support they will tell you it's your router's problem. I have tried different ways to debug the problem with no luck.
     
  12. john008 macrumors newbie

    Joined:
    Mar 3, 2011
    #12
    Same problem with my new mbp 2011 15".

    I've changed my channel id, set wpa in place of wpa 2.

    Still crashing on mac os x. Works fine with windows 7 :confused: ==> driver problem ?

    Cool, first Mac I've bought to use mac os x and can't.
    `

    I'm disgusted, will be returned this Saturday :mad:
     

Share This Page