Become a MacRumors Supporter for $25/year with no ads, private forums, and more!
  • Did you order new AirTags? We've opened a dedicated AirTags forum.

k3norton

macrumors newbie
Original poster
May 18, 2012
4
0
I just got an Iphone 3g - Version 4.0 (8A293), Modem Firmware 05.13.04

What steps do I need to take to jailbreak/unlock this?

I am new to this, never done it before....and really confused by all the lingo and specifics. What exactly are the right steps and what are the right programs I should use for my exact phone?

Thanks!
 

ideal.dreams

macrumors 68020
Jul 19, 2010
2,328
936
Ohio
Modem Firmware is irrelevant, only worry about the version of iOS your iPhone is currently running.
 
Comment

k3norton

macrumors newbie
Original poster
May 18, 2012
4
0
Modem Firmware is irrelevant, only worry about the version of iOS your iPhone is currently running.

thanks. It says to use itunes 9.2, but I have itunes 10.5.2.11. Will I need to downgrade my itunes to make this work?
 
Comment

Applejuiced

macrumors Westmere
Apr 16, 2008
40,672
6,532
At the iPhone hacks section.
Modem Firmware is irrelevant, only worry about the version of iOS your iPhone is currently running.

Modem firmare is Very very relevant in this case as he's trying to unlock.
And his baseband is unlockable without having to install the ipad baseband.
OP create a custom 4.2.1 with redsnow and restore to that.
Make sure NOT to upgrade to stock 4.2.1 or you will lose your unlockable baseband.
Use a custom IPSw and then install ultrasnow from cydia to unlock.
Find a tutorial on iclarified and ask plenty of questions if you dont understand anything.

thanks. It says to use itunes 9.2, but I have itunes 10.5.2.11. Will I need to downgrade my itunes to make this work?

You can update to the latest itunes version, that wont make any difference.
 
Comment

dhlizard

macrumors G4
Mar 16, 2009
10,214
119
The Jailbreak Community
Thread starter, just as a note, if you need to unlock this, do not update the baseband past where it is, or you lose the Ultrasn0w unlock.

If you ever choose to update the firmware, you must use a custom IPSW (baseband update is stripped out)
 
Comment

ideal.dreams

macrumors 68020
Jul 19, 2010
2,328
936
Ohio
I apologize, I overlooked that he was also trying to unlock his phone. Disregard what I said earlier!
 
Comment

JZTech101

macrumors member
May 15, 2011
72
0
East Brunswick, NJ
Modem firmare is Very very relevant in this case as he's trying to unlock.
And his baseband is unlockable without having to install the ipad baseband.
OP create a custom 4.2.1 with redsnow and restore to that.
Make sure NOT to upgrade to stock 4.2.1 or you will lose your unlockable baseband.
Use a custom IPSw and then install ultrasnow from cydia to unlock.
Find a tutorial on iclarified and ask plenty of questions if you dont understand anything.



You can update to the latest itunes version, that wont make any difference.
I'm Afraid, it is not relevant because of the device you are using. Because it is an iPhone 3G, an unlock is available regardless of the baseband version. I've personally restored regularly without issue. Just install Ultrasn0w from Cydia. (http://jailbreak-me.info/jailbreak-and-unlock-wizard.html).
 
Comment

Applejuiced

macrumors Westmere
Apr 16, 2008
40,672
6,532
At the iPhone hacks section.
I'm Afraid, it is not relevant because of the device you are using. Because it is an iPhone 3G, an unlock is available regardless of the baseband version. I've personally restored regularly without issue. Just install Ultrasn0w from Cydia. (http://jailbreak-me.info/jailbreak-and-unlock-wizard.html).

Thats false.
He has an unlockable baseband now that he can preserve and unlock without having to install the iPad baseband and deal with all the bad issues that come win that.
And once you do install the iPad you can never restore regularly again.
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.