Fix for High Unibody MBP Boot Camp Temps

Discussion in 'MacBook Pro' started by Full-Throttle, Mar 29, 2009.

  1. Full-Throttle macrumors member

    Joined:
    Jun 22, 2007
    Location:
    USA
    #1
    This is what I did to fix the high unibody MBP idle temps (I have only tried this on Windows XP).

    1. Download the latest GeForce Notebook drivers from nVidia's website.

    2. Run the installer. The installation will fail because it will not detect "Supported Hardware".

    3. Go to Device Manager, Click on "Display Adapters", and open the properties window for the 9600M GT.

    4. Click on the "Driver" tab, and choose "Update Driver".

    5. A driver wizard should come up, choose "Install from a list or specific location" and click "Next".

    6. Now pick "Don't Search" and click "Next".

    7. Select "Have Disk" and browse to this folder "C:\NVIDIA\WinXP\*Driver Version Number*\IS\Display", and click "Ok".

    8. A list of drivers should appear, don't click anything, just choose "Next".

    9. A warning should pop up, click "Yes".

    10. Let the installation finalize, then restart the MBP.

    Now your system should idle at a noticeably cooler temp than before. The reason it would run hot while idling is the Apple drivers never let the GPU clock down, so the GPU was running at max power all the time. Before I changed the drivers, my GPU would run in the low to mid 70's C while idle. Now it runs in the high 50's to low 60's C.

    My MBP still gets hot while gaming (high 70's to low 80's C), but that is what computers do under load. nVidia's website says that the 9600M is designed to operate up to 105C, so 80C is clearly below that. The best part about this fix is that it does not require SMC Fan Control and uses "Official" nVidia drivers and not "hacked" ones from laptopvideo2go.

    Hope this helps.
     
  2. jjahshik32 macrumors 603

    Joined:
    Sep 4, 2006
  3. simonpickard macrumors regular

    Joined:
    Mar 1, 2009
    #3
    "1. Download the latest GeForce Notebook drivers from nVidia's website.

    2. Run the installer. The installation will fail because it will not detect "Supported Hardware"."

    That's weird. I don't get this error? For me they install fine. However I'm not noticing the temps drop.

    What drivers did you download?

    Regards,
    Simon
     
  4. Full-Throttle thread starter macrumors member

    Joined:
    Jun 22, 2007
    Location:
    USA
    #4
    I used "GeForce Release 179.48 Beta for Notebooks". Do you have a unibody MBP and what OS are you using? Do you have "PowerMizer" enabled within the nVidia control panel?
     
  5. simonpickard macrumors regular

    Joined:
    Mar 1, 2009
    #5
    Hi there,

    I have a new 17" Macbook Pro unibody.
    Yep used the same drivers as you. I run Vista64 Bit.

    "PowerMizer"? Nope didn't see that? Is this the thing that auto slows the card down when not in use?

    Just had a look for it. Where's that located please?


    Many thanks,
    Simon
     
  6. Jottle macrumors 6502

    Joined:
    Oct 17, 2003
    #6
    The OP's method for updating the graphics card drivers is a very easy way to get the newest driver installed! I had to download the desktop drivers and then manually edit the .inf file to get it to recognize my 9600M on my unibody mbp. The desktop drivers have the drivers for the notebook cards as well, but my way was a b*tch to get working. Good call!
     
  7. Full-Throttle thread starter macrumors member

    Joined:
    Jun 22, 2007
    Location:
    USA
    #7
    I attached a screenshot of the setting in the nVidia Control Panel.
     

    Attached Files:

  8. simonpickard macrumors regular

    Joined:
    Mar 1, 2009
    #8
    Arhh is that Xp?

    I'm not sure that works in Vista.

    Regards,
    Simon
     
  9. Jottle macrumors 6502

    Joined:
    Oct 17, 2003
    #9
    Unfortunately, in vista there is no control panel option to disable the powermizer. There are, however, some hacks out there. And honestly, powermizer sucks for those of us that game. If you game in bootcamp, you definitely want to turn off the powermizer as it will throttle down your gpu on battery power or when it gets its temperature up= lowered fps on all your favorite games. For those of you who don't game in bootcamp, the powermizer will save your battery.

    Note: it doesn't matter if powermizer is supposed to automatically throttle your gpu. After 30min of gaming, powermizer will limit your gpu permanently until you either restart the card through the device manager or restart your windows partition. Do a web search as there are many pc users who hate the powermizer feature :)
     
  10. Full-Throttle thread starter macrumors member

    Joined:
    Jun 22, 2007
    Location:
    USA
    #10
    Yeah I am using XP and like I said, I have only tested this with XP. I believe you are right that PowerMizer does not work with Vista. It requires a registry "hack" to get it to work.

    Read this but remember, he is trying to disable PowerMizer, so you have to do the opposite: http://forum.notebookreview.com/showthread.php?t=261929

    I used that guide on a Dell XPS laptop and it worked great. 3333 for max energy savings, 3322 for max saving while on battery but full power when plugged in, and 2222 for full power on battery and AC.
     
  11. pyromaniaque macrumors 6502

    Joined:
    Nov 16, 2008
    Location:
    Well..Ask your mother.
    #11
    I wonder if this would actually also help with battery life.
     
  12. simonpickard macrumors regular

    Joined:
    Mar 1, 2009
    #12
    Ok I'm trying to get my head around this but have never done any Reg Editing.

    If I was trying to get the 9800GT to underclock how would I do this?

    What does 3333, 3322 and 2222 actually do?
    Are those the levels are powersaving?

    If you could give a quick run through of what I'd need to do in order to fix this I'd be most grateful.

    Regards,
    Simon
     
  13. simonpickard macrumors regular

    Joined:
    Mar 1, 2009
    #13
    Hello all!

    Just to inform you that I have successfully changed my registry based on the infomation at this website:

    http://aspiregemstone.blogspot.com/2009/01/nvidia-powermizer.html

    My temps have now dropped from:

    GPU: 85C
    Core 0: 57
    Core 1: 57

    to:


    GPU: 54C
    Core 0: 40C
    Core 1: 40C

    The laptop is cool, no more overheating, etc. Another plus point is that I'm now getting almost 4 hours battery life in vista!

    I'm very happy with this fix, and even though it's under clocking my gfx card slightly I haven't noticed any hit in the games that I've been playing.

    In fact there are even ways to get around this, eg, you can have 1 profile for Battery power and another for AC. So when you're on AC the GFX card will clock back to full speed.

    I have to say that this macbook pro is now perfect in windows vista 64Bit for me! :)

    Thanks again to everyone on this forum for all the help.

    Regards,
    Simon
     
  14. Full-Throttle thread starter macrumors member

    Joined:
    Jun 22, 2007
    Location:
    USA
    #14
    That is great! Glad I could help. I just don't get why Apple could not have done this when you install the Boot Camp tools?
     

Share This Page