Fix for Juniper Network Connect under Snow Leopard

Discussion in 'macOS' started by jaycarroll, Aug 29, 2009.

  1. jaycarroll macrumors regular

    Joined:
    Jun 19, 2009
    Location:
    Denville, NJ
    #1
    Likely not useful for most of you - but for anyone who happens to use Juniper Network's Network Connect app for ssl VPN access, here's how to fix post SL install. Apparently, SL messes with perms and removes the 'Frameworks' dir.

    http://www.thevagary.net/archives/2009/08/make_network_connect_work_in_s.html

    Code:
    sudo chmod 755 /usr/local/juniper/nc/[version number]/
    sudo mkdir '/Applications/Network Connect.app/Contents/Frameworks'
    
    Tested, works like a charm.

    -Jay
     
  2. jpecora2732 macrumors newbie

    Joined:
    Aug 29, 2009
    #2
    Worked great

    Thanks for the info it worked for me. We are running NC 6.1.0
     
  3. TheJacobTaylor macrumors newbie

    Joined:
    Aug 31, 2009
  4. fheijnen macrumors newbie

    Joined:
    Sep 1, 2009
    #4
    Wonderfull internet

    Good solution! These kind of issues would have taken me days in the past! The wonders of google.
     
  5. occamsrazor macrumors 6502

    occamsrazor

    Joined:
    Feb 25, 2007
    #5
    My company just rolled out 6.5.0 and it appears to work without the hack, though it's hard to tell for sure as I'd run the hack prior to upgrading. A full uninstall of 6.4.0 and reinstall of 6.5.0 and it still works though - without the hack. For what it's worth the hack worked fin for me on 6.4.0 and I didn't notice the slowdown that others had reported.
     

Share This Page