OS X Fix for Steam universal access glitch

Discussion in 'Mac and PC Games' started by saturnotaku, Aug 21, 2014.

  1. saturnotaku macrumors 68000

    Joined:
    Mar 4, 2013
    #1
    The latest Steam update, which drops support for OS X 10.5 among other things, introduced a bug that causes the program to ask for you to enable universal access for the in-game overlay even if it already was prior to the latest client release.

    Here's a fix for that glitch:

    1) Make sure Steam is not running and uncheck it from the accessibility preference pane.
    2) Close system preferences.
    3) Open Terminal and copy/paste the following exactly as you see it, including all quotes:

    Code:
    sudo sqlite3 /Library/Application\ Support/com.apple.TCC/Tcc.db 'delete from access where client like "%Steam%"'
    4) Re-open the accessibility preference pane and make sure that Steam is not listed.
    5) Close system preferences, launch Steam, and try to play a game. The warning dialog box about the Steam overlay will pop up again. Use it to go back into system preferences and Steam should have re-appeared. Check the box if it's not already, close system preferences, and you should be good to go.
     
  2. MichalM.Mac macrumors regular

    MichalM.Mac

    Joined:
    Mar 26, 2006
    #2
    Thank you for the tip
    I was to lazy to mess around with SQL in that sqlite db.

    Anyway.. it did not work.
    What version of Steam client do you have installed?
     
  3. saturnotaku thread starter macrumors 68000

    Joined:
    Mar 4, 2013
    #3
    Whatever the latest build is. Exactly what part did not work? Was Steam not removed from the accessibility list, or did it go away but the warning message reappear after you started Steam? Did you copy and paste the above code exactly as-is?
     
  4. Intelligent macrumors 6502a

    Intelligent

    Joined:
    Aug 7, 2013
    #4
    Can you tell me exactly what the command does? man tells me its a database thing. But thats just sqlite3 not what the actually command does.
    EDIT: apparently it just deletes it from System Preferences.
    Thanks.
     
  5. MichalM.Mac macrumors regular

    MichalM.Mac

    Joined:
    Mar 26, 2006
    #5
    Steam was removed from accessibility list.
    Command work perfectly.

    Unfortunately when I re-add it through Steam.app Steam overlay still does not work. I suspect some bug introduced in last Steam update is causing this.
     
  6. Washac macrumors 68020

    Washac

    Joined:
    Jul 2, 2006
    #6
    I just opened the access window and even though it was selected I just reselected and all was OK.

    Seems my problem was a bit different as access was already ticked but was not recognized.
     
  7. GoldfishRT macrumors 6502

    GoldfishRT

    Joined:
    Jul 24, 2014
    Location:
    Somewhere
    #7
    For a few days the overlay didn't work (with the latest update). I ended up restarting my computer and now it works fine.

    If any of you are still having issues, try enrolling in the Steam Client Beta (it's in your account options).
     
  8. betterservant macrumors newbie

    Joined:
    Jul 11, 2014
    #8
    Thx, works for me. Mac OS 10.10/ Latest version of steam
     
  9. Suture macrumors 6502a

    Suture

    Joined:
    Feb 22, 2007
    #9
    Thanks! Knowing how long it takes Steam to fix anything, I appreciate you posting this.
     
  10. janustifler macrumors newbie

    Joined:
    Nov 7, 2014
    #10
    It works

    It works for me.. but the problem is, after i do this and the dota 2 crash , i will do it again the procedure. how come Yosemite no update about this, hope valve will help us to fix this ASAP. its annoying.

    Thanks !
     
  11. ChipsAhoya macrumors newbie

    Joined:
    Nov 8, 2014
  12. kylionbuck macrumors newbie

    Joined:
    Nov 9, 2014
    #12
    My steam didn't remove from the list?

    My steam didn't remove from the accessibility list?
     
  13. cactuslick macrumors newbie

    Joined:
    Nov 6, 2011
    #13
    Thank you! This fix seems to be working for me. This has bugged me for so long... I finally got tired of waiting for a Steam update to fix it.

    I mostly followed the steps in the original post, except instead of running the terminal command I just removed Steam from the accessibility list normally by clicking the minus button while it was selected.
     
  14. bmac89 macrumors 6502a

    bmac89

    Joined:
    Aug 3, 2014
    #14
    I am also experiencing the same glitch. It asks for universal access even though it is already ticked. Each time I open System Preferences and un-tick and re-tick it works temporarily. The next time I start steam it does it all over again. I also notice steam freezes up very regularly at startup and I need to force quit, log out and try again. It means spending a long time just trying to start a game which would otherwise start with no problem if Steam was not involved.

    Also the internal Mac OSX firewall keeps asking me to accept/deny connections even though steam and the steam game is added to the always accept list.

    I am running OSX Mavericks 10.9.4
     
  15. mig0 macrumors member

    Joined:
    Nov 24, 2012
    #15
    The fix appeared to be working on both of my mac minis (i7 and i5 from 2012).
     
  16. andydckent macrumors member

    Joined:
    Jun 2, 2009
    Location:
    Edinburgh, Scotland
    #16
    Just deleted Steam from universal access by pressing the [-] key and then re-added by pressing [+] key and choosing from list of applications. That fixed it for me.
     
  17. mig0 macrumors member

    Joined:
    Nov 24, 2012
    #17
    My fix was short lived, it reverted back to the same problem once I changed accounts.

    I am retrying this but using andydckent's suggestion. It appears to work but I will need to try this out more extensively.
     
  18. mig0 macrumors member

    Joined:
    Nov 24, 2012
  19. Janichsan macrumors 65816

    Janichsan

    Joined:
    Oct 23, 2006
    #19
    The problem seems to be that the last couple of versions of Steam are apparently not properly code signed (or even not signed at all), which leads to this problem and in many cases also constant nagging of the firewall about Steam.

    This together with the problem which the latest Steam update introduced, that Steam on occasion no longer can find its own library and show no games to be installed, give me the impression that Valve has stopped giving the last damn about proper Mac support.
     
  20. cerote macrumors 6502a

    cerote

    Joined:
    Mar 2, 2009
    #20
    The new update for Steam has fixed it for me it seems.
     
  21. saturnotaku thread starter macrumors 68000

    Joined:
    Mar 4, 2013
    #21
    Yes, both universal access and firewall issues. Unfortunately it has not addressed the fact that I can't access the community/discussion areas beyond the landing page from within the client. Clicking on any link to go to a specific discussion page results in no response, not even the spinning page loading icon. This isn't a huge deal, but a fix would be lovely. I'm just glad that these two big ones got taken care of.
     
  22. Irishman macrumors 68030

    Joined:
    Nov 2, 2006
  23. mig0 macrumors member

    Joined:
    Nov 24, 2012
    #23
    Thats a problem Im sporadically having, where it tells me to install a game I was playing the day before, and the system just seems to parse through, looking for (and validating, I think not just redownloading) the files of the game in my library.
     
  24. jpnadas macrumors newbie

    Joined:
    Apr 30, 2014
    #24
    Fix worked for me,

    mac OS X 10.10
    latest steam client
     
  25. Irishman macrumors 68030

    Joined:
    Nov 2, 2006
    #25
    Latest Steam update says it fixed this bug, but did not.

    10.10

    steam update from 11/28
     

Share This Page