FIX for Yahoo Server problems, can't get mail from Yahoo

Discussion in 'iPhone' started by RonHC, Sep 22, 2012.

  1. RonHC, Sep 22, 2012
    Last edited: Sep 23, 2012

    RonHC macrumors 6502a


    Apr 27, 2010
    All my email services work in the mail application but yahoo. It doesn't even say if I entered the password wrong, it just says the server isn't available. Anyone else have same problem?

    Here's a video for a fix for those who are having a similar issue

  2. -Knight- macrumors 6502a


    Jun 25, 2010
    Miami, FL
    I'm getting the same issue and it's pissing me off. I had no problems with the iP4. Anyone found a workaround to get Yahoo mail to work??
  3. RonHC thread starter macrumors 6502a


    Apr 27, 2010
    glad I'm not the only one
    I tried deleting my yahoo account and still get the "Yahoo server is unavailable"
  4. Renaldo63 macrumors newbie

    Aug 15, 2012
    Getting Yahoo! Mail To Work On iPhone 5

    Hi -

    I had same problems, but got Yahoo! mail to work on my new iPhone5 by deleting the old Yahoo! mail account and setting up a new mail account by inputting the information below for a new Yahoo! imap mail account. Make sure to go to "Add Account" and choose "Other," not the Yahoo! template, then input your Yahoo! email information. It worked for me!

    How to set up IMAP on your mobile device
    ID: SLN3361Refers to: Mobile Mail , Mobile

    This article explains how to configure your mobile device to use Internet Message Access Protocol (IMAP).

    To set up Internet Message Access Protocol (IMAP) on your mobile device, please use the following settings:
    Incoming Server -
    Outgoing Server -
    Incoming Port - 993 (requires SSL)
    Outgoing Port - 465 (requires SSL/TLS)
    User name: full email address (for example, or
    Password: the password you log in to Yahoo! with.
    Note: If your Yahoo! Mail address does not match your Yahoo! ID, you will need to use the beginning of your Yahoo! Mail address when you set up your client. For example, if your Yahoo! Mail address is "", but your Yahoo! ID is "james", you will need to use "jim" as your user name when setting up the IMAP client.
    If you are having trouble setting up IMAP on your mobile device, we would recommend reviewing your phones instruction manual or contacting your mobile provider.
  5. Renaldo63 macrumors newbie

    Aug 15, 2012
    Getting Yahoo Mail To Work On iPhone 5

    Try this
  6. 28Gauge macrumors 6502


    Sep 4, 2011
    I'm having the same problem, but with only 2 yahoo mail accounts (I have several). I will try the fix listed above.


    I did the same thing earlier with the same results.
  7. 28Gauge macrumors 6502


    Sep 4, 2011
    This worked!!! Thanks for posting this solution!!!!
  8. Sherifftruman macrumors 6502

    Jun 23, 2010
  9. Renaldo63 macrumors newbie

    Aug 15, 2012
    Glad It Worked For You!

    Glad getting Yahoo! mail to operate worked for you!

    This is the first time I posted a solution and after the numerous times I have been helped on the forum, I am glad I could assist for once.

  10. Macintosh69 macrumors member


    Oct 16, 2008
    Thank You!

    OMG, I've been troubleshooting this all day...thank you for posting!

  11. barachus macrumors regular

    Jul 9, 2010
  12. RonHC thread starter macrumors 6502a


    Apr 27, 2010
    thanks it worked, heres a video if some people need help with it
  13. epicollector macrumors newbie


    Oct 20, 2012
    Corona, CA
    Alternate fix for Yahoo Mail Server Verification on iPhone 5

    The methods described in these threads did not work for me after deleting the mail account settings and creating an Other Account and entering the POP mail server settings for my Yahoo business account, however I did discover another method to correct the problem.

    The problem is that the Yahoo servers could not verify the iPhone 5 as an authorized device. I downloaded the Yahoo app and used it to verify the device. When you first enter your username and password, it will reset those fields and provide a verification box of letters and numbers. Enter that information (AND THE USERNAME AND PASSWORD again). This completes the verification process and Mail will work with your Yahoo account.

    If you have regular Yahoo mail, you can continue to use the Yahoo app as well as Mail. Unfortunately for me, business accounts are not supported in the Yahoo app, but the Mail app still made the connection and downloaded all of the email on the server and became functional as expected, using my original POP settings.
  14. howardc64 macrumors newbie

    Mar 14, 2011
    Only IMAP method worked for me. All other methods (Yahoo! app login, switch private browsing, change password etc...) didn't work. But IMAP method don't sync everything like address book which is highly desirable.

    This happened when I was switching from one iPhone to another via iCloud backup and restore. I think Yahoo's security measures must be at play here but of course they provide a cryptic error message.

    I just waited 12 hours and everything worked perfectly. This is the second time it happened like this (switched iPhone about a month ago and encountered the samething) I'm guessing Yahoo must have a time period to block mobile access due to what it thinks is suspicious activity.
  15. markymark1984 macrumors newbie

    Nov 8, 2012
    I had this problem too. Even the guy at the store i brought the phone from couldn't work it out :mad:

    Make sure you have the latest version of ios on the device. I found out a new update 6.0.1 is now out and after updating this allowed me to set up emails.
  16. kenn1940 macrumors newbie

    Nov 13, 2012
    Yahoo mail

    I contacted ATT office who ended up talking to Apple. Was told their is a problem with new operating system and it will beThursday of this week before their is a fix.:mad:
  17. Setsuka090 macrumors newbie

    Feb 13, 2013
    Thanks a lot

    Thanks a lot, hours of headache from yahoo solved by your tips.
  18. laurachill macrumors newbie

    Apr 12, 2015
    This works for Yahoo server problem

    Thanks for the post! This was the only thing that worked for me.

Share This Page