FIXED: Chronic Internet Problems Help Please!

Discussion in 'Mac Basics and Help' started by DoFoT9, Aug 20, 2008.

  1. DoFoT9 macrumors P6

    DoFoT9

    Joined:
    Jun 11, 2007
    Location:
    Singapore
    #1
    hey guys/gals

    ok i have a massive dilemma!

    somehow port 80 (and 8080) have closed on my computer....

    i cannot get onto ANY website, yet i still am able to chat to friends, check my email (through mail.app) and anything else not internet based.

    my question: how the hell do i fix it?!?!?!

    thanks in advance :)

    DoFoT9
     
  2. mkrishnan Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #2
    A good start would probably be providing some details... ;)

    For the specific computer that's having the problem: What kind of computer do you have? What OS and version does it run? What is the source of your internet connection (cable, DSL, etc)? What are all the devices (modem, router, etc, brand and model) that are between the wall and your computer? How are they connected (e.g. ethernet or USB, wirelessly, etc)?

    (P.S. Everything you listed is "internet based." Those things just don't use HTTP or the ports you describe).
     
  3. DoFoT9 thread starter macrumors P6

    DoFoT9

    Joined:
    Jun 11, 2007
    Location:
    Singapore
    #3
    ok well i guess i jumped the gun im totally freaking out. let me just say that i am certainly not a 'n00b' at computing and i have narrowed down the error to a port closure (from what i can tell).

    1. im on a CD MBP (see specs).
    2. its running 10.5.2
    3. the source of my internet connection is gigabit ethernet. i have already tried using wireless with no luck.
    4. i have my modem (gateway 2wire 2071-A) connected to my airport time capsule which which then connects to a switch which goes to my computers.

    i am able to access the internet from every other computer in my house.


    i find it extremely odd that i can connect to MSN, and gmail (through mail.app) yet cannot get onto any websites. i have tried using safari and firefox with no success.

    i opened up network util and ran a port scan on my computer and cannot see port 80 nor 8080 open (from what i understand is used for web browsing).

    i think what might be adding to the problem is that when i go to uni we use a VPN program to "log" us onto their network. i have closed down this program already and restarted the computer, then tried both wifi and ethernet, this didnt work.

    :(
     
  4. mkrishnan Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #4
    Sorry, I do know you're not a n00b. ;) But details are details.

    So...

    - I take it you're not running anything like little Snitch that could be blocking the ports, and you'd know it if you were.

    - The network diagnostic tool shows all green balls, even though you clearly do not have a fully working connection, and that you have a valid IP address being distributed to you?

    - Does turning the firewall off temporarily change anything?

    - Does creating a new "location" in the network prefs change anything? If it does, you might need to use the location setting to manage separate preferences when you're at uni and when you're not (although that's kind of odd... I use the VPN on my Macs periodically and it should not have this effect of screwing up the Mac when it's not connected).
     
  5. DoFoT9 thread starter macrumors P6

    DoFoT9

    Joined:
    Jun 11, 2007
    Location:
    Singapore
    #5
    p.s. i just opened up port 80 and nothing has happened, it doesnt come up in network util as 'open' but it does come up in terminal when i type "sudo ipfw list"

    my firewall is allowing all incomming connections
     
  6. SpookyLars macrumors 6502

    Joined:
    Jul 21, 2008
    Location:
    Poland
    #6
    I think that maybe sth wrong in firewall configuration? Look at the firewall rules. To list all rules type in Terminal: sudo ipfw list.
    If you want to clear all firewall rules, type: sudo ipfw -q -f flush.
    Manual for ipfw: man ipfw.

    Warning! Be extremely careful with Terminal! If you not sure about what are you doing, just don't do it!
     
  7. DoFoT9 thread starter macrumors P6

    DoFoT9

    Joined:
    Jun 11, 2007
    Location:
    Singapore
    #7
    nope no programs at all blocking ports i can guarantee that.

    network diagnostics tool is showing ALL green even though web sites seem to be not working.

    i created a new location and had no luck with that either, i have noticed that under network settings there is "802.1X" with the name of the uni network. there is no option to delete it so im guessing that it just stays there (this happened when i made a new location aswell)

    "firewall says 65535 allow ip from any to any."

    i opened up port 80 and it says the above aswell as
    "00100 allow tpcp from 0.0.0.80 to 0.0.0.80

    not gonna flush the firewall bceause im not that good at terminal haha

    thanks for your help guys im still baffled though!
     
  8. mkrishnan Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #8
    That's really odd... have you poked around in your security settings? Maybe in Leopard there's something new that defaults to requiring 802.1x authentication once you set it up, that you can turn off?
     
  9. DoFoT9 thread starter macrumors P6

    DoFoT9

    Joined:
    Jun 11, 2007
    Location:
    Singapore
    #9
    had a look and cannot see anywhere to change the settings for 802.1X access, so it must be there by default.

    when i go through diagnostics it says everything is ok. that must mean that its using a different port to the http port doesnt it??

    argh so angry.

    thank you so much for your information and help.
     
  10. DoFoT9 thread starter macrumors P6

    DoFoT9

    Joined:
    Jun 11, 2007
    Location:
    Singapore
    #10
    the problem seems to have sorted itself out now (after a few good hours of fiddling)
     

Share This Page