Fixing a dead iPod touch 2G

Discussion in 'iPod touch' started by animeshtripathi, Jan 7, 2012.

  1. animeshtripathi, Jan 7, 2012
    Last edited: Jan 7, 2012

    animeshtripathi macrumors newbie

    Joined:
    Jan 7, 2012
    #1
    Hi all,

    My faithful iPod touch 2G (8GB) just died. It was working fine in the morning and I was even streaming songs over Bluetooth. But when I picked it up from the table to check the time, it didn't respond at all. Didn't show any signs of being alive. And I know that it has atleast 50% charge on it. So yeah. Then, being a seasoned jailbreaker and iOS guy, I tried all methods to bring it back to life, the Home+Power button method, the method where you plug the iPod in while pressing the Home button, even tried using it on 3 different computers and my dock and wall charger. No response. Then, sometime later, I tried to insert a headphone jack into it, randomly. It started up! I opened Doodle Jump just to see if all my apps were still working, and it started, but apparently the accelerometer wasn't working (I wasn't able to control the game). Then the iPod suddenly froze. I thought it was alright, so I turned it off by holding the Home and Power buttons continously. It turned off, but the pixels on the screen still showed a faint resemblance of the screen at which it froze. I tried to turn it on again. No response :mad:

    I have since been trying to make it work again. It's out of warranty. I opened it up by removing the top bezel and digitizer using some guitar picks. I've kept it to dry under a lamp for more than 24 hours, just in case it has some moisture damage. But it isn't responding at all.

    What else should I try? I'm sure everything in this iPod works perfectly, I had around 50 apps, lots of songs, regularly used it on WiFi, it was working perfect till the morning. The fact that it started up once indicates that it's some minor problem. How do I go about fixing this?

    Update: Surprisingly, the water indicator inside the iPod is red. :O Probably due to moisture.

    Animesh
     
  2. verwon macrumors 68030

    verwon

    Joined:
    Jul 26, 2011
    Location:
    Seattle
    #2
    Probably due to moisture? Ummm...yeah!
     
  3. animeshtripathi thread starter macrumors newbie

    Joined:
    Jan 7, 2012
    #3
    ^

    No, seriously, I have a proper case on it and I don't like to keep my iPods underwater -_-

    Its pretty humid here, probably the reason for the red indicator.
     
  4. animeshtripathi thread starter macrumors newbie

    Joined:
    Jan 7, 2012
    #4
    It works!

    I left it to dry for some more hours under a light bulb, and then left it connected to my wall charger for a few more hours. I started it up by pressing Home and Power, and it works!!! :D:D:D:D:D
     

Share This Page