Fixing AFP support to older servers

Discussion in 'Mac OS X Lion (10.7)' started by ginkaninka, Jul 23, 2011.

  1. ginkaninka macrumors newbie

    Jul 23, 2011
    This post may prove useful to some:

    I have tested this to allow connection to Netware 6.5 servers running AFP 3.1, Windows 2008R2 servers running ExtremeZ-IP (AFP 3.2) and my home NAS box.

    In summary:
    1) Launch /Applications/Utilities/Terminal and do:
    sudo chmod o+w /Library/Preferences
    defaults write /Library/Preferences/ afp_host_prefs_version -int 1
    Now restart your computer.
    2) From Finder, select an AFP server, or use “Connect To…”. This will cause the AFP Client to create the full preferences file
    3) Launch Terminal again and do:
    sudo defaults write /Library/Preferences/ afp_disabled_uams -array “Cleartxt Passwrd” “MS2.0″ “2-Way Randnum exchange”
    sudo chmod o-w /Library/Preferences
    Now restart your computer.

    Note: To add a “DHCAST128″ to the disable list, use
    sudo defaults write /Library/Preferences/ afp_disabled_uams -array-add “DHCAST128″
  2. djrbx macrumors member

    Jul 12, 2011
    North Hollywood, CA
    Just a heads up to people, this does not fix TimeMachine if your NAS device supports it. You'll have to wait for an upgraded firmware fix from the manufacturer of your NAS device to use TimeMachine.
  3. tdar macrumors 6502a

    Jun 23, 2003
    On the Space Coast
    + also remember that the only NAS's that will be fixed are those running linux.
    And only at vender discretion.
  4. Eric8199 macrumors 6502a

    Feb 27, 2009
    Thank you SO MUCH for this. Wasn't sure I was going to be able to access my work server on my personal computer anymore. Thank you!
  5. Takuro macrumors 6502


    Jun 15, 2009
    This is pretty odd, but an official Apple support document now actually lists this hack. Now that this confirms that Apple is aware of the issue, I wonder why they don't make it easier to enable compatibility with older AFP servers (such as providing a small warning message the first time you connect.)
  6. Glenndk macrumors newbie

    Aug 12, 2011

Share This Page