Fixing my partition scheme...

Discussion in 'macOS' started by The General, Feb 4, 2007.

  1. The General macrumors 601

    Jul 7, 2006
    Okay so I installed Debian just to mess around with stuff, but now I want to remove it. This should be simple, right? Wrong... :(

    I have this:

       #:                   type name               size      identifier
       0:  GUID_partition_scheme                    *149.1 GB disk0
       1:                    EFI                    200.0 MB  disk0s1
       2:              Apple_HFS Macintosh HD       120.0 GB  disk0s2
       3:             Linux Swap                    1.9 GB    disk0s3
       4:   Microsoft Basic Data                    27.0 GB   disk0s4
    I don't know why my 27GB ext3 paritition shows up as Microsoft Basic Data, but whatever, it doesn't matter.

    All I want to do is turn 3 and 4 into free space, and resize 2 to fill the rest of the drive.

    How do I do that? :(

    Also, when I run Boot Camp Assistant, it tells me this:


    How do I fix that?

    Thanks :eek:
  2. islandmonusvi macrumors newbie


    Nov 29, 2006
    U.S. Virgin Islands
    Check versiontracker for various partition utilities.
    Partitioning can be tricky business...
    or start from your install CD and use Disk Utility to partition ...
    before doing anything ... back up !!!
  3. The General thread starter macrumors 601

    Jul 7, 2006
    Don't ask why, but I didn't back up ...

    I booted to my Mac OS X DVD, and I ran Disk Utility. I seleted the partitions, and erased them as MacOS HFS+ Journaled partitions. So I had 3 HFS+ partitions. Then I went to the disk and I when to the partition tab, and I selected the middle partition and hit delete. It resized the look of the Macintosh HD one, so I clicked on the second one I wanted to delete, and hit delete on that. Then I hit "partition" and I think it erased the entire harddrive.

    Eh... There's only one file on it that's irreplaceable ... it's just gunna be a pain in the ass to have to download all my stuff again ... how do I recover some files from it? I mean, it didn't do a low level format or anything, I'm fairly certain the data still exists on it. :(

Share This Page