Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

maroontigre

macrumors newbie
Original poster
Mar 17, 2010
27
0
Some of us have had a problem syncing multiple Google Calendars to the iPad. Here's a fix:

Enable the Safari debug on your Mac.
Set the user agent to iPhone
Go to m.google.com/sync
Turn off JavaScript
Select your iPad device
Select your calendars (it should work)
Disable/re-enable your calendars through the Exchange account you established on the iPad
There you have it

Thanks to Eric et al on the Google Help forums
 

xraydoc

macrumors demi-god
Oct 9, 2005
8,607
2,689
192.168.1.1
Some of us have had a problem syncing multiple Google Calendars to the iPad. Here's a fix:

Enable the Safari debug on your Mac.
Set the user agent to iPhone
Go to m.google.com/sync
Turn off JavaScript
Select your iPad device
Select your calendars (it should work)
Disable/re-enable your calendars through the Exchange account you established on the iPad
There you have it

Thanks to Eric et al on the Google Help forums
Thanks!
 

dgdosen

macrumors 68020
Dec 13, 2003
2,037
696
Seattle
Sweet!

Thanks for the tip, brother.

For a second there, I thought we'd be limited to syncing one calendar.
 

Fazzl

macrumors 6502a
Aug 13, 2007
579
4
Some of us have had a problem syncing multiple Google Calendars to the iPad. Here's a fix:

Enable the Safari debug on your Mac.
Set the user agent to iPhone
Go to m.google.com/sync
Turn off JavaScript
Select your iPad device
Select your calendars (it should work)
Disable/re-enable your calendars through the Exchange account you established on the iPad
There you have it

Thanks to Eric et al on the Google Help forums

So I enabled debug mode via the terminal. How do I "Set the user agent to iPhone"? I don't see any option in the debug drop down menu...
 

dgdosen

macrumors 68020
Dec 13, 2003
2,037
696
Seattle
So I enabled debug mode via the terminal. How do I "Set the user agent to iPhone"? I don't see any option in the debug drop down menu...

I did this on my desktop with Safari - Select, Preferences, Advanced, and you'll see a develop menu option - enable that and then you can see the User Agent option, which lets you make your desktop mimic the iPhone browser...
 

igadhia

macrumors newbie
Jul 16, 2008
2
0
hello,

I just sync my ipad with the machine, mail, calendar etc all work on the ipad.

when I try the above fix , I get to the manage devices and I cant see the ipad on the list! whats happening?
 

kes601

macrumors regular
Aug 3, 2008
182
0
So I enabled debug mode via the terminal. How do I "Set the user agent to iPhone"? I don't see any option in the debug drop down menu...

You are making it too difficult :)

In Safari, Go to Prefs / Advanced and enable Develop Menu. That is where you can change the User Agent.
 

jgctx

macrumors newbie
Jun 10, 2009
29
0
great,but...

It looks like there is one solution to sync multiple calendars with my ipad and that is Google? so how does that work if I am already using an exchange account on my ipad. I currently have 4 email accounts set up, 1 is exchange and the other are imap(one is a google account). I looks like I would have to change my current exchange account to another type of mail account, is that right? I was hoping for a simpler solution. Any ideas?

This looks like an opportunity for a good developer to make some cash to make a calendar app that can work with multiple input.
 

SophiaViolet

macrumors newbie
Dec 21, 2010
5
0
I completed all of the steps and my calendars still won't sync. I created an Exchange account on my iPad for my gmail account and my calendars wouldn't show up. I have my gmail account set up on my iPad and the only calendar (out of like... 7) that shows up is the calendar I never use and has the same name as my account.

As a side note that may or may not be related to the issue; I can sync all of my gmail calendars to my iCal program on my MacBook Pro. I tried syncing my iPad to my iCal (via iTunes) and the gmail calendars that show up in iCal still will not show up on my iPad.

Does anybody have an suggestions or tips?
 

Mawal

macrumors regular
Aug 19, 2010
128
0
you need to your go to this page with your Ipad:

m.google.com/sync


The language on Google must be English, now you can choose your calendars.
 

SophiaViolet

macrumors newbie
Dec 21, 2010
5
0
you need to your go to this page with your Ipad:

m.google.com/sync


The language on Google must be English, now you can choose your calendars.

I did that - made sure ALL of my calendars were selected not just the one that is currently showing up on my iPad. I went back to the calendar app and still nothing showed up except for that one. Then I went to my settings and turned off the calendar option for Exchange AND Gmail, turned them all back on, went back to the calendar app and still nothing showed up.

I can't figure out what I'm missing to make it not work... :(
 

Mawal

macrumors regular
Aug 19, 2010
128
0
I did that - made sure ALL of my calendars were selected not just the one that is currently showing up on my iPad. I went back to the calendar app and still nothing showed up except for that one. Then I went to my settings and turned off the calendar option for Exchange AND Gmail, turned them all back on, went back to the calendar app and still nothing showed up.

I can't figure out what I'm missing to make it not work... :(

Check the following points:


1. Have you set up your google mail account as an exchange account on your Ipad?

2. Did you select the new calendars on your calendar app on the Ipad?


I have set up four IOS devices with multiple calendars, it works flawlessly for me.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.