Flash 10.1 Issues on 2010 MBP I7

Discussion in 'MacBook Pro' started by chuckm1020, Jun 11, 2010.

  1. chuckm1020 macrumors regular

    Joined:
    Aug 27, 2009
    #1
    So yesterday i saw the announcement that 10.1 came out for flash and went on adobes website to install it. The installation went perfect. At first I tried some videos on vimeo and hulu. When i went on fullscreen mode it was very very choppy. Both on HD videos and regular 480p videos. I noticed the graphics card stayed on the Intel. When i went on youtube the video card switched over to the 330m for all videos and all videos ran smoothly in full screen mode, including 1080p of course. So i manually switched to the the 330m and tried out hulu and vimeo again in full screen. Silky smooth after doing that. Doesnt make sense its choppy on all videos with the Intel video card. I dont remember it doing this before upgrading to 10.1. I was curious and uninstalled flash 10.1 and figured ill try out the 10.1 with gala to see if that made a difference. exact same results as above. I have no clue whats going on. Of course ive done many restarts and even tried to repair permissions for the heck of it. Currently I stayed with 10.1 with Gala because i dont know what to do. I dont even know how to go back to the previous version of flash i had. 10.0.... i guess it would be :p
     
  2. djasterix macrumors 6502a

    djasterix

    Joined:
    Apr 10, 2010
    Location:
    Paradise City
    #2
    I hada hard time trying to install Gala, so I left my MBP with the older version.
     
  3. kpsfire macrumors newbie

    Joined:
    Jun 11, 2010
    #3
    Same problem here, also running on a 2010 MBP i7. From the Activity Monitor, I can see the CPU usage spike dramatically when running a flash app with the Intel graphics compared to the NVIDIA, but some flash applications are broken altogether.

    Update: A simple uninstall and reinstall did the trick for me. Head over to the uninstall webpage and download the uninstaller, then reinstall. Video is still choppy, but at least it works again.
     
  4. prism macrumors 6502a

    Joined:
    Dec 6, 2006
    #4
    Has anyone noticed after installing gala or 10.1, if you have your GPU set to dynamic switching and you right click a youtube video to chose "settings", the computer enters an endless switching cycle between the two GPUs and you need to force quit the web browser to stop the switching.
     
  5. stylinexpat macrumors 6502a

    stylinexpat

    Joined:
    Mar 6, 2009
    #5
    Goto www.gsmarena.com and let me know if your laptop runs hot after about 5 minutes or so. I had a few tabs open and had left the gsmarena website running in one of my tabs and after a few minutes the computer got quite hot and the fans seemed like they were on max. Couldn't figure out why the computer was running so hot but when I finally closed the gsmarena website things went back to normal. I guess Apple does not like websites with flash on them..:confused:
     
  6. revbarabbas macrumors regular

    Joined:
    Apr 27, 2009
  7. UTclassof89 macrumors 6502

    UTclassof89

    Joined:
    Jun 10, 2008
    #7
    ... And the winner for Most Moronic Quote of the Day is....


     
  8. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #8
    NO it doesn't.

    http://www.macrumors.com/2010/06/10...-hardware-acceleration-on-os-x-not-supported/
     
  9. revbarabbas macrumors regular

    Joined:
    Apr 27, 2009
    #9
  10. chuckm1020 thread starter macrumors regular

    Joined:
    Aug 27, 2009
    #11
    Well I get the choppy results with 10.1 Gala and 10.1 official release without Gala. Does anyone know how to go back to the last version I had before 10.1?
     
  11. milkybrainuk macrumors newbie

    Joined:
    Jan 31, 2008
    Location:
    UK
    #12
    If you testing out the Gala version of Flash player make sure you use the uninstall on adobe site at the bottom of the page when switching between the different flash player versions. Don't just install over the top of them

    http://labs.adobe.com/downloads/flashplayer10.html
     
  12. revbarabbas macrumors regular

    Joined:
    Apr 27, 2009
    #13
    The solution that Adobe proposes is to clear your browser cache....don't know how that will help but it's worth a try.

    To go back to the earlier version go here and download the one you want:

    http://kb2.adobe.com/cps/142/tn_14266.html

    I would try to uninstall it first, restart your Mac...Reinstall Gala or vanilla 10.1...then restart again...then fix permissions and clear your browser's cache and see if that helps you out.
     
  13. chuckm1020 thread starter macrumors regular

    Joined:
    Aug 27, 2009
    #14
    Thats what I have been doing many times. Ive uninstalled, restarted, repaired permissions many time. Haven't tried clearing cache though. i will try that right now. And i do uninstall it every time before i install another one. I believe you don't have to download the uninstaller from adobe. If you go to application then utilities there is an adobe uninstaller in there. Looks to be the same.
     
  14. chuckm1020 thread starter macrumors regular

    Joined:
    Aug 27, 2009
    #15
    Ok clearing Cache didnt work :(. Here are the steps ive been doing to uninstall and install(Use uninstaller to uninstall from adobe, restart, clear permissions, restart, install flash, restart, clear permissions, restart) lol. Thats when i was going crazy and tried everything. I guess ill try going back to original and see if that works. But question, when i go to http://kb2.adobe.com/cps/142/tn_14266.html to get the previous version. Then i go down to ARCHIVED VERSIONS do i choose the first one, Flash Player 10? And why is it 157mb? When i download the newer versions its around 7 in a half MB? Thanks for all your help :)
     
  15. xlii macrumors 68000

    xlii

    Joined:
    Sep 19, 2006
    Location:
    Millis, Massachusetts
    #16
    A while back I installed the gala 10.1 beta. Still have it on and I think it works great, no issues. I tried to install this latest 10.1 offical release and it told me that I have a newer version of flash already on my system. I know I could delete the gala beta and install this just released official 10.1 version... but something is telling me to leave well enough alone.
     
  16. chuckm1020 thread starter macrumors regular

    Joined:
    Aug 27, 2009
    #17
    So I downgraded back to 10.0R45 flash(wich I believe was the last version) and the issues i was having are a all fixed. No more choppiness withe the Intel HD graphics card. I just don't get it!! :(:(
     
  17. mr.economy macrumors newbie

    Joined:
    Jun 25, 2009
    #18
    I'm glad I found this thread, because I was really starting to wonder if I had a defective MBP. I'm on the 15" 2.4ghz i5, running Flash 10.1 (not Gala) and first noticed the issue trying to watch the Daily Show in full screen. It's choppy and completely unwatchable when full-screened with the IGP active, but things are perfectly smooth when I use gfxcardstatus to force the 330m.

    For comparison and a little perspective on just how messed up things are, I just loaded the same Daily Show episode on my 1.8ghz late-2006 MacBook, and it ran perfectly smooth in full screen. This is unacceptable.
     
  18. dennarda macrumors newbie

    Joined:
    Jul 8, 2007
    #19
    Flash 10.0 fixes this

    I was having the same problem on an i7 17" MBP. I'm guessing Flash 10.1 has an issue with the new auto switching graphics card setup. Uninstalling Flash, downloading the flash 10 archive and installing the last version of Flash 10 (10r45_2) made everything run much better. It still isn't as good as it SHOULD be, but at least full screen jerkiness is minimized. Since almost every site on the net uses flash in some capacity (at least ads) this has fixed a lot of general sluggishness issues for me.

    I hope this gets fixed for real soon.
     

Share This Page