Flash Drive issue I can't find

Discussion in 'Mac Apps and Mac App Store' started by abailey21, May 22, 2009.

  1. abailey21 macrumors newbie

    Joined:
    Jul 29, 2008
    Location:
    Tampa Florida
    #1
    So I use a flash drive in my vehicle for music, I normally load a 4Gb and have at it. I haven't done anything different than I normally do, other than unplugging it and plugging it into my iMac.

    So I try to load some music on it this morning and I get a popup telling me it's write protected and I can't do anything with it?

    I opened up the disc utility, but I can't repair, format, verify or anything else because it's write protected. Normally with Windows I was able to right click and hit properties and remove this, I tried on my gaming PC and no joy there either.

    anyone know of any tricks to this?
     
  2. Fizzoid macrumors 68020

    Fizzoid

    Joined:
    Jul 11, 2008
    Location:
    UK
    #2
    Very strange, it should at least format even if the files on there are write protected. Have you tried formatting it on a Windows machine?
     
  3. MacRUK macrumors newbie

    Joined:
    May 18, 2009
    #3
    Sound mechanical.

    Is there a tiny little switch that may have been moved ?
     
  4. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #4
    This is almost always caused by one of two things, with flash drives:
    1. Most flash drives have a tiny hardware write-protect switch. Check this, to make sure it hasn't accidentally been flipped.
    2. Check the format of the drive - if it's NTFS you won't be able to do much with it without a 3rd-party utility. I don't think this is likely though, since you say you can't even format it.
     

Share This Page