Flash drive not readable by this computer

Discussion in 'Mac Accessories' started by hail-seitan, Jun 30, 2014.

  1. hail-seitan, Jun 30, 2014
    Last edited: Jun 30, 2014

    hail-seitan macrumors newbie

    Joined:
    Jun 30, 2014
    #1
    I got this error when inserting a flash drive: "The disk you inserted was not readable by this computer." I tried to put it on two old PCs at work and I'm either even worse at using PCs than I thought, or it flat out didn't acknowledge that I put anything in.

    It isn't my flash drive. The owner had some files I needed saved on there, but I don't want to accidentally erase anything else that might be on the flash drive. These files are important so I'm really concerned...

    I opened Disk Utility since I saw that was recommended when I did a Google search, but this is what it shows... I can't click verify.

    [​IMG]

    I tried to restore it to another USB and it said:
    "Restore Failure
    Could not validate source - error 254"

    Please tell me the data is not lost forever...

    (sorry if this is the wrong forum)
     
  2. thedeske macrumors 6502a

    Joined:
    Feb 17, 2013
    #2
    did you try selecting disk1s1 instead of sandisk?
     
  3. hail-seitan thread starter macrumors newbie

    Joined:
    Jun 30, 2014
    #3
    Yeah, didn't work... but for some reason it did work on someone else's computer and I managed to get the files. I'm still really annoyed that it isn't working because it just doesn't make any sense, but I guess no damage done...
     
  4. thedeske macrumors 6502a

    Joined:
    Feb 17, 2013
    #4
    Good for you - now you can reformat the flash drive if needed. If it's a desdski, no worries, they're darn cheap ;)
     

Share This Page