Flash Drive Not transfering at USB 2.0 speed

Discussion in 'Macintosh Computers' started by stephenrydalch, Dec 28, 2004.

  1. stephenrydalch macrumors newbie

    Sep 7, 2004
    Hey everybody,

    I have a USB 2.0 flash drive (a 256mb SanDisk MicroCruzer) that I am using with my 1ghz 12" powerbook. The problem I am having is that the drive does not do data transfers at 2.0 speeds. It's transfer rate is much slower and seems more like USB 1.1.

    The transfer speeds are fine on all windows machines I have tried it on but I have the exact same problem on every Mac that I've tried. Each mac, including my own, is running OS 10.3.7.? and is fully updated.

    The OS X system profiler recognizes the device as being capable of speeds up to 480mb/s. I did notice that in the info screen for the drive it says the device is formated as MS-DOS. I reformated the drive in OS X extended journal format but that didn't affect the transfer speeds, it only made my available space smaller. I called Sandisk, they told me to call Apple and vice versa. Anyone have any suggestions? Thanks.

  2. jackieonasses macrumors 6502a


    Mar 3, 2004
    the great OKLAHOMA....
    What speeds are you achieving? it is only 256megs, so how fast (or slow) is it going?
  3. stephenrydalch thread starter macrumors newbie

    Sep 7, 2004
    Well, it's hard to get an exact clock on the speeds but as I stated they are very similar to speeds I experience if I'm using a USB 1.1 drive.

    To upload or download 250 mb's takes roughly 4 minutes.
  4. adrianl331 macrumors newbie

    Jan 13, 2005
    "...USB 2.0 is not yet an officially supported standard on the Mac. All Macs continue to ship from Apple with USB 1.1 ports installed. USB 2.0 interfaces do work, but on operating system versions prior to Mac OS X they operate at the slower 1.1 speed. FirewireDirect confirmed with MacCentral that this card will operate at the slower USB 1.1 speed when used with Mac OS 8.6 - 9.2; on Mac OS X, USB 2.0 speeds are supported..."

    I've also read rummors that there are third-party drivers or patches floating around that address the USB 2.0 bottleneck in Mac OS's as it appears to be a software issue rather than hardware? But I've yet to come across them, if anyone else does or knows more, please post. Thanks!
  5. CrackedButter macrumors 68040


    Jan 15, 2003
    51st State of America
    What a crappy thing to say, USB 2 does work, I have a pen drive, the thing carries over PSD files no problem quite fast (for example). Plus, you cannot install older operating systems on a new mac so what are you talking about?

    (Original Poster)
    Your problem might problem might be in the flash memory. maybe it cannot transfer fast enough over USB2.
  6. kettle macrumors 65816


    May 12, 2002
    England, Great Britain (Airstrip One)
    Does USB2 actually mean that the flash ram inside is fast enough to utilise the full speed of the bus?
  7. combatcolin macrumors 68020


    Oct 24, 2004
    Northants, UK
    USB 2 IS (or WAS) slower on Mac than pc.

    But its something that i think was sorted in a recent panther upgrade.

Share This Page