Flash Drive Problems

Discussion in 'Mac Accessories' started by wdencker, Feb 28, 2011.

  1. wdencker macrumors newbie

    Joined:
    Jun 30, 2008
    #1
    Five months ago I purchased a 16 gigabyte Crucial flash drive from the Apple Store. Just today, when trying to plug it in, the drive would not mount, let alone give an LED flash. I thought the problem had to do with one of the four connections being broken, so I pried open the flash drive and soldered each of the four connections. That helped a little bit, because now if I hold it the right way I can get the LED to come on for a short instant, but the drive will still not be recognized on the desktop. I have tried this on multiple Macs and one PC, and still cannot find success. I have important papers that are due soon on the drive, and do not care whether or not the usability of the drive is preserved. I just want the data. Is there any way to get the data from the device? Thanks in advance.
     
  2. G5isAlive macrumors 6502

    Joined:
    Aug 28, 2003
    #2
    led light comes on for a short instant?

    sounds like a really bad connector. I might be tempted to get another housing (since you have already gone this far) and connector and replace it. after that you will likely want to boot up disk utility, it can sometimes see drives that do not mount up.

    good luck...
     
  3. wdencker thread starter macrumors newbie

    Joined:
    Jun 30, 2008
    #3
    Yes, now the LED light comes on for about 3 seconds, while usually it blinks on and off in a distinct pattern if it's working properly. I have also tried to fix it with Disk Utility before, but it still will not be even recognized by the computer. I'm contemplating taking in this thing to a professional, although it might be expensive, because I think the data is still on the device. Thanks for your help, and any other advice would still be appreciated.
     

Share This Page