flash on my website doesnt work locally

Discussion in 'Web Design and Development' started by pelsar, Aug 5, 2008.

  1. pelsar macrumors regular

    Joined:
    Apr 29, 2008
    Location:
    israel
    #1
    i have a flash menu system....online all works great. However when i am opening the files locally on my computer the flash menus dont work. I'm sure there some code that i should be adding.....

    and while i'm on the subject, on the PC when opening the website online, it wants permission before playing the flash...i'm sure there is some code to get around the "permission" question.....
     
  2. SrWebDeveloper macrumors 68000

    SrWebDeveloper

    Joined:
    Dec 7, 2007
    Location:
    Alexandria, VA, USA
    #2
    Please define "locally", i.e. does that mean within Flash MX or later, or do you mean a localhost version of your web site via browser?

    The most common reason is developers using absolute paths instead of relative paths, so it only works on the web server for which it was written. Also, if localhost issue, explain your setup - I suggest using MAMP, and always use relative paths so the site performs the same on both, regardless of domain.

    As to permissions, maybe that's referring to your browser's security settings and/or any pop-up blockers or anti-spyware/spam software plugins added into your browser. Sometimes it's just asking you to upgrade to a newer version of the Flash plugin. Set security settings to default for Internet zone, always install the latest Flash plugin when/if prompted.

    If you're using a security certificate to encrypt the data or for e-commerce puposes and Flash is involved in that specificially, please let us know (doubtful) as that advice is special.

    Since your information was general, the advice here is general. If none of this advice helps, post relevant code or a link please to the working web site so we can at least determine the actual paths involved. Thank you.

    -jim
     
  3. pelsar thread starter macrumors regular

    Joined:
    Apr 29, 2008
    Location:
    israel
    #3
    locally...

    the website via my browser.....all the links are relative. When i take the whole folder and dump it on a server so that its on line, it all works find. That very same "index file" when on open it via a browser while its on my harddisk, the flash menus no longer work. The files are all simple html
     
  4. SrWebDeveloper macrumors 68000

    SrWebDeveloper

    Joined:
    Dec 7, 2007
    Location:
    Alexandria, VA, USA
    #4
    So I take it the general advice I gave didn't help. Please refer to my last two sentences in my previous reply, thanks!
     

Share This Page