Flash suddenly not working

Discussion in 'macOS' started by jonkun227, Aug 10, 2010.

  1. jonkun227 macrumors newbie

    Joined:
    Jun 8, 2010
    #1
    So my brother calls me today saying he's having trouble with his Mac. (This is what happens when you "convert" someone: any trouble and they go straight to you.) He recently bought a new 27" iMac. It's gorgeous. Far cry from the Mac Mini he bought to try out Mac OS.

    Anyway, he's been using the system long enough that I believe him when he says he has a problem. But I was skeptical when he said that Safari/youtube say that he needs to update Flash player, and he said that he had already done that. I took over his machine through iChat (I LOVE the VNC ability built-in!) and went through the full update process again. (He had already done the repair permissions routine. I saw the log. There were remarkably (concerningly?) many bad permissions found, but it seems like an unlikely culprit.)

    Sure enough, even after doing the Adobe updater to the latest version youtube still says he needs to update.

    I went to http://www.adobe.com/software/flash/about/ and discovered that it is very different on his screen than it is on mine: Mine shows a flash-based advertisement for another product, and a flash-based current version notifier, plus a chart showing the latest version available for different operating systems. His only shows the chart. The flash-based content is completely missing. Doesn't EVEN say to update/upgrade.

    Checked in Firefox. Exactly the same behavior. It's as though Flash isn't even installed, but I know it is.

    Any ideas? This is so odd. Was working fine, now nothing.

    Thanks for any help or insight you can provide!


    - Jon
     
  2. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #2
    If you try to view a YouTube video, do you see nothing but white space until you double click where the video should be, then you see it playing in full screen?
     
  3. LPZ macrumors 65816

    Joined:
    Jul 11, 2006
  4. jonkun227 thread starter macrumors newbie

    Joined:
    Jun 8, 2010
    #4
    That was my thought. I gave him that link and he did the whole uninstall bit, then reinstalled following the download link from that page and it still didn't work.

    I went back in and verified that it wasn't working, then probed around a bit. For some reason the install file he was using was for Flash 9, not 10. He says he got it from that main Flash download page and that he did indicate that he was using Mac OS X 10.6. I deleted every old installer I could find (there were a few that must have been copied by old programs or something, going back to Flash 7) then downloaded and installed the correct one and it worked.

    Still no idea how it suddenly stopped working. It was for months and even just a few days ago. The only thing he's changed was getting a new Comcast modem (the old one quit working entirely) and he went through the Comcast self-install website thing that connects with the right account and all that stuff. Can't imagine that would have screwed up Flash, but maybe?


    Anyway, thanks for your help!


    - Jon
     

Share This Page