Flash video works good in preview, is MIA on the web

Discussion in 'Web Design and Development' started by Thomas Veil, Oct 22, 2007.

  1. Thomas Veil macrumors 68020

    Thomas Veil

    Joined:
    Feb 14, 2004
    Location:
    OBJECTIVE reality
    #1
    I'm having trouble with something relatively simple -- inserting a Flash video into a web page.

    I've seen all the tutorials, but I must be missing something because (1) it's not obvious or (2) I'm dense.

    The process I used:
    • imported a QT movie into Flash, and turned it into an .flv file
    • put the .flv into a folder with the skin and FLVPlayer, in our web site's local folder
    • uploaded the folder to the remote server
    • opened the page locally in Dreamweaver and inserted the .flv
    • uploaded the page to the remote server
    Here's where it puzzles me. When I preview the page in a web browser, the Flash movie plays just fine. But when I go out on the web, the movie's not there, just a white placeholder.

    I've checked to see that the same files I have locally are also on the remote server, so I'm not sure what's wrong.

    FWIW, here's the web page into which I inserted the video. (It's a dummy copy of our actual front page.) I know the site design is bad -- it's not mine, I just took over its maintenance. :eek: But I'd really appreciate any hints you could give me as to what I'm doing wrong.
     
  2. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
    #2
    You talk of a flv file, but I only see a swf. But don't think that's the issue. I took the swf and tried to load it by itself independent of the code and it still gave a white screen.

    How exactly are you viewing it locally when it works?
     
  3. Thomas Veil thread starter macrumors 68020

    Thomas Veil

    Joined:
    Feb 14, 2004
    Location:
    OBJECTIVE reality
    #3
    Via Dreamweaver's browser preview function. The browsers I previewed in are Firefox and IE6, on a PC.
     
  4. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
    #4

Share This Page