Flash won't play in Firefox

Discussion in 'Web Design and Development' started by editoremma, Mar 25, 2010.

  1. editoremma macrumors newbie

    Joined:
    Dec 26, 2007
    #1
    Hi, I've created a website with Flash. When I test it locally it runs just fine in Safari and Firefox. When I upload it, it will still play in Safari, but in Firefox it comes up with the following message: You have chosen to open a document, What should Firefox do with this file? Open it or Save it.
    I just can't get it to open.
    I have tried using HTML pages with embedded flash files created using Flash and Dreamweaver - no difference.
    Please help - I've been all over the internet and can't find what the problem is.
     
  2. ryketech macrumors newbie

    Joined:
    Oct 15, 2009
    #2
    Have you tried running Firefox in safe mode? If it works then you have an extension or block problem.

    Start> Mozilla Firefox> Mozilla Firefox (Safe Mode).
     
  3. editoremma thread starter macrumors newbie

    Joined:
    Dec 26, 2007
    #3
    Won't work in Safe Mode

    Thanks for the suggestion, I never knew that option was available.
    I have tried opening the site in 'Safe mode' and it came up with the same error. If you can tell me what that means and if it helps figure out what is going on, that would be great.
     
  4. BillyBobBongo macrumors 68020

    BillyBobBongo

    Joined:
    Jun 21, 2007
    Location:
    On The Interweb Thingy!
    #4
    Do you have a link to this page, or can you post the HTML text here?
     
  5. editoremma thread starter macrumors newbie

    Joined:
    Dec 26, 2007
    #5
    URL for testing

    Hey,

    Here is the URL: www.emmaspencerfilms.com/

    Thanks for taking a look.

    By the way, this flash file was written in Actionscript 2, not 3. I don't know if that makes a difference.
     
  6. editoremma thread starter macrumors newbie

    Joined:
    Dec 26, 2007
    #6
    Working Now

    Thanks to everyone who has looked at this thread and responded with advice or opinion.

    The site is working well now, it was a problem with where I was hosting the site and not actually a problem with either Flash or Firefox.

    Thanks again.
     

Share This Page