Flashing AGP card - Partial success

Discussion in 'PowerPC Macs' started by weckart, Aug 1, 2014.

  1. weckart macrumors 68040

    Joined:
    Nov 7, 2004
    #1
    I had a spare Radeon 9500 Pro card (275MHz clock) from an old PC I am gutting. I identified the exact card I had per the Macelite website and it suggested I use a 9700 Pro ROM (rev 130). This is the second card I have flashed so I am familiar with the process. I flashed this in the PC with a DOS utility.

    The flash went fine with no errors. I carefully covered rear pins 3 and 11 only per the guide on Macelite and slotted the card in a QS 2002 with the Molex to 4 pin power cable connected.

    The machine booted up with no complaint but I get screen artifacts as per the picture below. It is the same under OS9 as under Tiger except that my mouse cannot click on anything under OS9. I suspected my taping of the pins was subpar so I had several goes and am happy with my handywork. The QS boots happily with other cards so it is something specific with the card rather than the QS. Is there some other cause I am missing?
     

    Attached Files:

  2. harrymatic macrumors 6502

    Joined:
    Dec 30, 2013
    Location:
    United Kingdom
    #2
    There's nothing wrong with the pin taping - if there was, the computer wouldn't even power up. It's posible that the card is clocked too high, try using ATIcellerator to reduce the memory and GPU core clock speeds. (you may need to use VNC / screen sharing to do this as you can't really see much with the card in this state)

    I had a similar situation when I flashed a GeForce 6800GT a while back, in the end I just tried all of the ROMs on the Mac Elite that might work, then worked on tweaking the clock speeds on the ROM which worked the best. In the end, the card still went into my junk box as it's not compatible with the MDD G4s. A real shame too, as if it worked properly, it would have wiped the floor with the ATi Radeon 9800XT I found instead.

    Hope this helps!
     
  3. weckart, Aug 1, 2014
    Last edited: Aug 1, 2014

    weckart thread starter macrumors 68040

    Joined:
    Nov 7, 2004
    #3
    I am suspecting my card is one of those that only has a 64kb ROM. It flashed with a 128kb ROM succesfully. From what I can see ATIflash v3.10+ overrides the 64kb block. Not good.

    I have a PCI FX5200 somewhere. Need to dig that out but that will take hours to find in my storage.


    [EDIT] Tried the 64kb ROM and the 9500 ROMs via screen sharing and same result each time. Will try ATIcellerator before giving up.

    On the upside, I just scored a 23" acrylic ACD for a tenner. Oh, dear. More room eaten up.
     

Share This Page