Flashing Folder Icon on Startup?

Discussion in 'MacBook Pro' started by ZebraTalent, Feb 20, 2018.

  1. ZebraTalent macrumors newbie

    ZebraTalent

    Joined:
    Mar 8, 2009
    #1
    Hi all,

    I've googled this, and there seems to be a few reasons for this. But just wondering if anyone might be able to clear up whether my situation is resolvable.

    So, I (seemingly stupidly) inserted a windows CD into my MacBook Pro in an attempt to fix my windows partition (I forgot I should use bootcamp assistant!). The CD loaded to the welcome screen of the Windows installer.

    I turned off the MacBook by holding down the power key, and turned it on using the shortcut to eject the Windows CD.

    When I tried to turn the MacBook on again to load up Mac OS, I was greeted with a flashing folder icon with a question mark on it.

    I have tried booting the laptop holding down the option key and:
    - Performed 'Repair disk' on 'Macintosh HD' - It completes and gives me the message 'The volume Macintosh HD appears to be OK'. It then says, 'Updating boot support partitions for the volume is required.' (Any idea how I do this?)

    - I also tried performing repair disk on the BOOTCAMP partition. It doesn't give me a success message per say, but does say 'Volume repair complete'.

    - When I try and perform disk repair on the 'Toshiba media' it says 'Storage system repair or verify failed'

    - I also seem to have a greyed out disk0s3 partition that when I try and repair disk in it says, 'Disk utility can't repair this disk.'

    I don't particularly care about the Bootcamp or disk0s3 partitions, but if anyone has any advice on if it's possible to get the Mac OS working again, that would be much appreciated! :)

    Thanks in advance for any help, and I apologise if this has been posted in the wrong forum!
     
  2. Bending Pixels macrumors 65816

    Joined:
    Jul 22, 2010
    #2
    First - what Mac OS are you using? From there, I'd suggest downloading that version and create an install USB. It sounds like the WinDoze installer CD borked not only the BOOTCAMP partition, but also the other partitions.

    Once you create the install USB, boot your MBP with the USB inserted and hold down the option key. Choose to boot to the USB install drive. The installer includes Disk Utility which will show you what partitions are there, and possibly provide a fix by deleting the BOOTCAMP and other partition.

    You might wind up having to totally reformat the drive to get it up and running.

    Just my humble opinion, but the second best way to run Windows is to run it as a VM. The first best way is to buy a cheap laptop.
     
  3. ZebraTalent thread starter macrumors newbie

    ZebraTalent

    Joined:
    Mar 8, 2009
    #3
    I believe it was High Sierra! May have been the one before though. If I create an install USB, does that format what is on the HD already?
     
  4. Fishrrman macrumors G5

    Fishrrman

    Joined:
    Feb 20, 2009
    #4
    You can't create a USB flash drive installer using Windows.
    This MUST be done using the Mac OS.

    You've just learned why I don't recommend BootCamp unless one absolutely, positively HAS to have the ability to boot into Windows.
    Rather, an "emulation solution" (VMWare, Parallels, Virtual Box) is the better way to go.

    I'd find another way to boot the Mac (external bootable drive).
    Then I'd backup whatever Mac stuff is on the internal drive.
    Then I'd ERASE the internal drive to HFS+ with journaling enabled.
    Then I'd install a version of the Mac OS -other than- High Sierra (which seems to be a bag of hurt right now).
    Then I'd install VMWare (or an alternative) and install Windows into that.
     
  5. ZebraTalent thread starter macrumors newbie

    ZebraTalent

    Joined:
    Mar 8, 2009
    #5
    Hey guys, so I decided to format the HD and do a clean install of Windows 7 only (not through OSX). It installed OK, and I have downloaded the Apple Bootcamp software (version 4), but the install runs particularly slowly - as in it takes time to right click chrome and open a new windows. When I had my previous install of Windows set up through bootcamp, it ran absolutely fine!

    Does anyone have any ideas? It doesn't look like I need to update any drivers.

    Thanks again for any help! :)
     
  6. hwojtek macrumors 65816

    hwojtek

    Joined:
    Jan 26, 2008
    Location:
    Poznan, Poland
    #6
    Bad idea. Should've run from the Recovery HD partition, reinstall the OS X and you'd be set.
     
  7. ZebraTalent thread starter macrumors newbie

    ZebraTalent

    Joined:
    Mar 8, 2009
    #7
    Thanks! Will give it a go :)
     

Share This Page