Flashing folder - probably not cable or motherboard..?

Discussion in 'MacBook Pro' started by datorjävel, Apr 28, 2017.

  1. datorjävel macrumors newbie

    Joined:
    Jan 1, 2017
    #1
    Hi

    My macbook have started messing with me (again). I have a new SSD so it's not the problem. I had the flashing folder about two months ago so I changed the SATA cable and it started working again.

    A few days ago it started behaving weirdly, took around 5 minutes to start up. I ran a s.m.a.r.t test which gave me a warning about data transfer. I don't remember what it said but I concluded that it was either the cable or the motherboard. So I took it apart and made sure the cable was in place and I also ran apple advanced hardware tests which said that nothing was wrong with the motherboard.

    Started it up twice yesterday, first I got the flashing folder and then the startup was like normal. Today, however, it gives me the flashing folder again. So it's working semi-normal (except a little slower than usual) sometimes and sometimes it doesn't work at all.

    What could possibly be wrong with my computer? It is an early 2011 13".
     
  2. duffyanneal macrumors 6502a

    duffyanneal

    Joined:
    Feb 5, 2008
    Location:
    ATL
    #2
    I wouldn't totally discount this being an SSD issue. They do fail. Do you have the original drive you can install just to do a sanity check? If you still see the issue with the old drive then you're back to the cable or motherboard.
     
  3. reserves macrumors member

    Joined:
    Feb 10, 2009
    #3
    I had this issue and reinstalled all the whole operating system, I then had the 2012 Retina checked by Apple and it passed all tests.

    The 'Genius' said it could have been firmware corruption, sounds vague..
     
  4. datorjävel thread starter macrumors newbie

    Joined:
    Jan 1, 2017
    #4
    I honestly don't think it's the SSD. It's about six months old and I haven't written much on it. Of couse I could be wrong but my guess is that it isn't the problem. I don't have the old hdd unfortunately, it crashed which is why i changed it.

    I will try to reinstall the OS and see if it fixes things.
     
  5. andy9l macrumors 68000

    Joined:
    Aug 31, 2009
    Location:
    England, UK
    #5
    I bought an SSD for my '09 MBP a few years back, it died only a few weeks later with barely any use. Same issue - one day just got the flashing ? folder.

    Got given a replacement, and that's still working well today. Just the luck of the draw.
     
  6. logicstudiouser macrumors 6502

    logicstudiouser

    Joined:
    Feb 4, 2010
    #6
    I know exactly what you are talking about with that flashing folder cause it happened to me.
    For me, it was the SSD. I bought an OCZ ssd that turned out not to be compatible with my macbook pro, which was also a 2011. Samsung EVO works great in the 2011 macbook pro.
    Other possible cause is the SATA cable, if you haven't done so already, you might want to replace the SATA cable. They can do it at the Apple Store but it will probably cost around $50. The computer is over 5 years old and if you are keeping it for the long term, it is probably a good idea to do it anyway even if the SSD is ultimately the cause of this issue.
     
  7. datorjävel thread starter macrumors newbie

    Joined:
    Jan 1, 2017
    #7
    Yea, I have the Samsung EVO. I tested with another EVO that is in my SO's macbook and it isn't the HDD that is at fault. So I guess there's no use reinstalling the firmware?

    That leaves me with either the motherboard or the SATA cable. Since the apple hardware test didn't show any faults with the motherboard I'm guessing the problem is in the cable, which is unfortunate since I changed it it just 35 days ago. Now I'm just hoping ifixit will let me change it for a new one.
     
  8. Fishrrman macrumors G5

    Fishrrman

    Joined:
    Feb 20, 2009
    #8
    Take it to a brick-n-mortar Apple store.
    They have a free replacement program for the internal SATA ribbon cable.
    Not sure if yours will qualify, but it's worth a try.
    In any case, they'll give it a good "looking over"...
     
  9. ZapNZs macrumors 68020

    ZapNZs

    Joined:
    Jan 23, 2017
    #9
    It sounds like the replacement cable may have had some fault. FWIW, I've thrown several SMART errors in enclosures with problems with their SATA interface...IIRC they were something like CRC and IO errors?

    You could try throwing the SSD in a Thunderbolt or USB2 external and booting it to ensure it isn't some other cause?
     
  10. datorjävel thread starter macrumors newbie

    Joined:
    Jan 1, 2017
    #10
    Exactly, CNC was the error I got. Forgot the name of it. I'm certain it isn't the HDD because I tried with another, working SSD, and I got the same error.
     
  11. Fishrrman macrumors G5

    Fishrrman

    Joined:
    Feb 20, 2009
    #11
    OP:

    Get ahold of an external fully bootable drive.

    If you have a spare HDD or SSD, you can use either a USB3/SATA dock, a USB3 enclosure, or even a USB3/SATA adapter/dongle.

    Boot from the external drive.
    Do things run well?
    If this is the case, and you find you still have problems booting and running from the internal, it again points to the ribbon cable...
     

Share This Page