Flashing question mark folder on startup

Discussion in 'macOS' started by Penny's Geek, Nov 17, 2010.

  1. Penny's Geek macrumors member

    Oct 25, 2008
    Need some help from all of you Mac Gurus out there.


    Last week I woke up to do my usual thing of checking email and all social networking sites, etc.. I touched the trackpad to stop the screensaver and engage my MBP only to find the beachball spinning so I had no choice but to completely shut the computer down. I did a hard boot and when trying to start everything up again, all I got was a blank light screen. For whatever reason, it would not boot. I tried all of the known fixes for this and nothing worked. I finally managed to get it to a flashing question mark folder which means the file system was hosed.

    So, I find that most Mac Gurus recommend Disk Warrior for this so I broke down and bought a copy. So when it arrived, I put it in and let it do its thing. It said that things were fixed and the directory structure was repaired and so, being optimistic, I quit DW, rebooted, only to find the flashing question mark folder still there. I tried and tried to restore OSX via Carbon Copy Cloner but it wouldn't work. That left me with no choice but to re-install OS X and then Snow Leopard.

    My question after all of this, is why suddenly, with absolutely NO WARNING whatsoever, the file structure would suddenly get corrupted? Yes, its sounds like a hard drive either going bad or is bad. Now, I do computer repair work on the pc sides of things so am not completely clueless about it. It's a little different on the Mac but I'd like to know what you guys think? A

    The hard drive is brand new. I bought a 500GB Seagate drive a few months ago and installed it myself. Worked just as it should. I put a new one in because soon after upgrading to Snow Leopard, I started getting the spinning beachball on each use. Most forums suggested it was a bad hard drive so I got a new one. Problem solved. Now this. The only thing that makes sense to me is either this new drive is going bad (drive utility says is fine) or the many hard boots I've sometimes had to do has somehow played havoc with the boot loader.

    It's the first time this has happened and I've had this MBP since the latter part of 2008. It's the best computer I've ever owned and am wondering why this happened?

  2. mulo macrumors 68020


    Aug 22, 2010
    Behind you
    the flashing question mark means it cant find the OS, usually a quick fix around this is to hold option during boot, this allows you to manually select the boot volume. Then select it in system prefs so you dont have to do it over and over.

    999th post!
  3. Gregg2 macrumors 603

    May 22, 2008
    Milwaukee, WI
    How do you know that?
  4. MacDawg macrumors Core


    Mar 20, 2004
    "Between the Hedges"
    View your profile
  5. Penny's Geek thread starter macrumors member

    Oct 25, 2008
    I did that and it didn't work. It didn't find anything. It did find my restore disk which at the time I wasn't ready to go the re-install route.
  6. Penny's Geek thread starter macrumors member

    Oct 25, 2008

    I saw this while trying to figure out WHY this happened in the first place. Why all of a sudden would this happen when I've already put a new hard drive in, if in most cases it's the hard drive that causes this? I think it almost has to be something else. What that is, I hope the rest of you can help me with.

Share This Page