flashing question mark on Ibook G4

Discussion in 'PowerPC Macs' started by Juelz, May 9, 2009.

  1. Juelz macrumors newbie

    Joined:
    May 9, 2009
    #1
    i got my ibook G4 about 5 years ago and has worked great.
    about a year ago however, a vase of water got dumped on it while it was open and on.. i quickly unpluged it and forced it off and then took out the battery and flipped it upside down to let it dry out.. it didn't work for nearly 3 months and then one day it just started working again..? had some problems like shutting off for no reason and it would have a fit if you unplugged it to fast. it was slowly getting better and i figured it was finally drying compleatly out. (it obviously still had some power problems though)

    during a power outage the mac shut off again and then just wouldn't start again... a few days of just not coming on it started to work and let me turn it on but the only thing it showed was a flashing mac icon followed by a question mark..

    it acts as if it can't find any files at all? any idea what i can try to fix it? is it even fixable?

    thanks!
     
  2. jonbravo77 macrumors 6502a

    jonbravo77

    Joined:
    Feb 20, 2008
    Location:
    Phoenix, AZ
    #2
    I'm sorry to say that I hope you have a backup of everything. Typically the flashing ? is a sign of hard drive failure in that it can't find the boot sequence. You can try to put your systems disk in and boot from that and do a repair permissions.
     
  3. Juelz thread starter macrumors newbie

    Joined:
    May 9, 2009
    #3
    the mac was second hand when i got it, and i've had it for 5 years so i don't have any disks that may have come with it.

    i tried to hold down the option button while turning it on and it sent me to a page showing the "recycle" icon and a "forward" icon... what does that mean?
     

Share This Page