Flashing Screensaver

Discussion in 'macOS' started by M3G4, Apr 6, 2009.

  1. M3G4 macrumors regular

    Joined:
    May 4, 2007
    Location:
    Kent, UK
    #1
    Hi all,

    Been having some issues with my iMac where when the screensaver launches, it instantly goes back to the desktop and then launches again, making it look almost as if it's flashing on and off. I used to get this with my old iMac as well. Has anyone else had this problem and is there a fix for it?
     
  2. M3G4 thread starter macrumors regular

    Joined:
    May 4, 2007
    Location:
    Kent, UK
  3. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
  4. M3G4 thread starter macrumors regular

    Joined:
    May 4, 2007
    Location:
    Kent, UK
  5. snowmoon macrumors 6502a

    snowmoon

    Joined:
    Oct 6, 2005
    Location:
    Albany, NY
    #5
    All the time or some of the time? After a reboot?

    Every screen saver or only some? which ones?

    Any other interesting software or tweaks?

    Have you cleared your screen saver prefs?
     
  6. AppleNewton macrumors 68000

    AppleNewton

    Joined:
    Apr 3, 2007
    Location:
    1 Finite Place
    #6
    try the basics...unplug all devices but mouse & keyboard, restart, reset pram (COMMAND OPTION P R at start up)


    attempt to let it goto screensaver again...if it doesnt do it anymore, add the extra peripherals one at a time and test...could be some sort of communication issue between a device and the system.
    noticed an ipod or iphone connected?

    i had this issue when i used remote screen sharing/remote login from within Leopard....i dont take it your connected remotely or someone is connected to you?
     
  7. M3G4 thread starter macrumors regular

    Joined:
    May 4, 2007
    Location:
    Kent, UK
    #7
    I would try this, but unfortunately it occurs completely at random! I can't test it as it won't happen until it wants to! :(
     
  8. snowmoon macrumors 6502a

    snowmoon

    Joined:
    Oct 6, 2005
    Location:
    Albany, NY
    #8
    Do you have a hot corner for "activate screen saver"?
     
  9. jpfreestyler macrumors newbie

    Joined:
    Apr 18, 2009
    #9
    same issue

    I have just had this issue, I have just switched to the bluetooth mouse from wired, maybe its dropping connection. Any more ideas ?
     
  10. snowmoon macrumors 6502a

    snowmoon

    Joined:
    Oct 6, 2005
    Location:
    Albany, NY
    #10
    Make sure the mouse is clean as a single hair in the detector can cause the mouse to "twitch".
     

Share This Page