Flashing XFX Radeon HD 487A ZWFC

Discussion in 'Mac Pro' started by vivniko, Aug 21, 2010.

  1. vivniko macrumors newbie

    Joined:
    Jun 6, 2007
    #1
    Hello,

    I recently purchased the XFX HD-487A-ZWFC Radeon HD 4870 1GB from Newegg to flash and use in my 2007 Mac Pro (2,1). I have tried flashing the card several times, but with not that much luck.

    First of all, here's my setup:
    3GHz Quad-Core Intel Xeon Mac Pro 2007 (2,1)
    8 GB Memory
    10.6.4 with recent graphics update
    30" Apple Cinema Display (2560 x 1600)

    I am upgrading from the Nvidia Quadro FX 4500. I have a spare Nvidia GeForce 7300 GT card that I am using while trying to flash my new ATI Radeon.

    The first thing I tried was booting with the Radeon in slot 1 and the GeForce 7300 in slot 4, using the latter for the display. No luck, I just got a blank screen. I have an older Alienware PC that can successfully use the new Radeon card (although due to it's age I'm guessing it's probably only 2x or 4x power). I downloaded the latest version of Winflash, but that said it couldn't replace the ROM so I went with version 2.0.1.2, which was linked to in this guide. I decided to try and flash using Naaaaak's modified ROM, since it sounds like my graphics card is the same. The Alienware only has one PCIe slot, so I was flashing the active graphics card. Winflash showed the message "Programming VBIOS: Please wait. Flashing is in progress, it may take more than a minute....." with an 80% progress bar for about an hour, and then it reported that it successfully replaced the VBIOS. I put this graphics card into the Mac Pro and plugged my display into it – as I booted the screen showed a lower-res version of the standard grey Apple logo, and the computer was able to boot in 1280 x 800 resolution. I installed the latest ATI drivers through Cindori's Zeus tool, and restarted. Upon restarting, I got the low-res Apple logo again, but then a blank screen after a few seconds. I put the computer to sleep using the power button, and after I woke the computer back up the screen came to life in full 2560 x 1600 resolution.

    Sounds like a happy ending, right? The card was fully recognized by the Mac, with full resolution and everything. As I moved my cursor through the dock it was quite laggy/choppy. Portal couldn't start since it claimed that my system didn't meet the minimum system requirements (although this isn't the case). StarCraft 2 claimed that it was missing certain files so it couldn't start and required a reinstall (it could and has started fine when I use the 7300 GT). Based on the Expansion Slot Utility that popped up, the Radeon card was at full 16x power (the utility only showed up because my GeForce 7300 was not at full 8x power in slot 4). So although the graphics card seemed to be supported fine in theory, it didn't seem to be gaining it's full potential.

    I decided to create my own ROM and give that a go. I followed the instructions in the XYZ.zip from Cindori's Golden Guide. During the process, I ran into some issues with specifying the directories in the terminal code, but I was able to generate a modified ROM that seemed to be fine (it has two MCuC's). I just successfully flashed this new ROM I created, using the older version of Winflash on the Alienware. The Mac Pro displays nothing when using the Radeon graphics card for the display. And it is a little buggy when I have it inside while using the 7300 GT for the display – it recognizes both graphics cards properly in the Graphics/Displays tab of the System Profiler, but reported an error that it was unable to display PCI information when I changed to that tab.


    I'm getting slightly frustrated at my current flashing state and current progress. I would love to hear any sort of help/tips you guys have. I've attached my original ROM as well as the modified one I created, and my graphics card info from GPU-Z. If someone could try and whip up a modified ROM for me, or take a look to see if my modified one is bad, that would be great.

    For future flashing trials, would it help if I first flash my card with the original ROM to restore it before flashing with a modified ROM? Or can I just go ahead and flash the modified ROM like I've been doing?

    Thanks for your help!
     

    Attached Files:

  2. Cindori macrumors 68040

    Cindori

    Joined:
    Jan 17, 2008
    Location:
    Sweden
    #2
    1st, the New Zeus can make rom for you automatically


    2nd, 4870 does not need driver patch through zeus, but some cards need to use older framebuffers, aka mapp.zip and dualdvi.zip, see my earlier posts on this
     
  3. vivniko thread starter macrumors newbie

    Joined:
    Jun 6, 2007
    #3
    Yay! Cindori comes to save the day!

    I did not realize that the latest version of Zeus can make the modified ROM for me, that's really neat! It took me a little bit to figure it out, but it successfully created a modified ROM.

    I successfully flashed the new ROM onto the card using my Alienware this morning. When I put the card into the Mac Pro, it worked the same as with Naaaaak's modified ROM I had tried earlier. The grey Apple startup displayed at a lower resolution (1280 x 800), the spinning pinwheel worked for a few minutes, and then the screen went blank. I put the computer to sleep using the power button, and once I woke the computer the display showed up at full resolution. The Expansion Slot Utility showed up and reported that it was running at full 16x power. As I dragged the cursor through the dock, it was choppy again. Both Portal and StarCraft 2 couldn't start, and they had the same errors I mentioned earlier.

    I grabbed the dualdvi.zip and mapp.zip, and tried installing the following from both:

    ATI4800Controller.kext
    ATIFramebuffer.kext
    ATISupport.kext

    The Kext Helper always reported that the kexts seemed to be installed fine, and I should cross my fingers and restart :)
    This did not seem to do anything, however, and the graphics card works the same choppy way as before.

    What else can I do? I didn't find much explanation on what to do with the kexts –*did I perhaps do something wrong, or should I try some of the other ATIRadeonX2000 etc kexts included in the mapp.zip?
    Would it perhaps help if I went back to Snow Leopard 10.6.3, or 6.4 just without the graphics update?

    Is it normal for a flashed graphics card to boot in this way – where it starts up to a blank screen and the user must put the computer to sleep and wake it in order to get the picture to display?

    Thanks for all your help so far, and for writing the awesome Golden Guide and Zeus, Cindori.
     
  4. audio_inside macrumors regular

    Joined:
    Oct 7, 2003
    Location:
    Boulder CO
    #4
    You mean your Desktop image is blank, or the entire screen is blank? I have never seen the latter phenomenon, but if the former, there is some state which DOES record which Desktop image goes with which card and in which slot. So moving cards around different slots might make a difference.

    And which version (C.0, E.0, G.1, etc) of the ZWFC are you using?

    Installing all the mapp.zip kexts did the QE/CI trick for me on my Ver. C.0 ZWFC (an XFX warranty exchange from my G.1) . There's no README but I'm going to go back now and see exactly which versions were in that patch.

    FWIW, I have occasionally had replacement kext installs not "take" until I did a Safe reboot, probably relating to kext caches being rebuilt. That was the final part of my mapp solution.

    I have not tried dual monitors yet.

    -Steve
     
  5. audio_inside macrumors regular

    Joined:
    Oct 7, 2003
    Location:
    Boulder CO
    #5
    I should mention that to get acceptable OpenGL performance after the ROM edit I also had to install the patches that Keita 1 gave a link to in this post.

    My benchmarks sped up by around 5x.

    -Steve
     
  6. rarz macrumors newbie

    Joined:
    Sep 13, 2010
    #6
    help!

    Hey audio_inside, could you please post your original and modified rom? I have the same version (zwfc C.0) but accidentally I formated the pendrive where I saved the original rom...:( Can't do anything right now, would be really appreciated if you upload them!

    Thanks!
    -j
     
  7. audio_inside macrumors regular

    Joined:
    Oct 7, 2003
    Location:
    Boulder CO
    #7
    ZWFC Rev C.0 ROMs

    The attachments are the original XFX HD478A ZWFC Rev C.0 ROM and the EFI-compatible one created by Zeus that I used to reflash my card.

    -Steve
     

    Attached Files:

  8. rarz macrumors newbie

    Joined:
    Sep 13, 2010
    #8
    Thank you man! I flashed it with your modified rom and atiflash but now I get a black screen when I boot. There's no way to enter in osx/windows/dos when the 4870 is plugged, even if my ACD is plugged in my old 7300 gt. I've tried changing slots for cards with no luck. I have to unplug my 4780 in order to see the grey apple logo. Any ideas? May it have died?

    I have a mac pro 1,1 with 10.6.4.

    Thanks in advance!
     
  9. audio_inside macrumors regular

    Joined:
    Oct 7, 2003
    Location:
    Boulder CO
    #9
    I dont think you would have bricked it but dont know for sure without having been there. I flashed mine with Zeus so I cant say what atiflash params would have been the correct ones for this unit.

    You say you cant even boot into Win/DOS so I assume you have Bootcamp installed? An alternative is to try reflashing with the stock ROM on an actual Windows box.

    -Steve
     
  10. marshaul macrumors newbie

    Joined:
    Oct 10, 2010
    #10
    Have you tried putting the computer to sleep (briefly pressing the power button) and waking it back up?

    My card gives me a black screen at boot, but when I do the above, it works fine. I noticed that another user in this thread had that problem, which is where I got the idea.

    Does anybody have any idea what's causing this behavior? If it could be resolved my card would be working quite nicely.

    My card is a ZWFC E.0, BTW.
     
  11. johhhn macrumors newbie

    Joined:
    Mar 16, 2010
    #11
    Soooooo, verdict for this card? don't buy it? Is the video, etc., accelerated?

    I don't care how it boots up as long as everything else works 100%!

    thanks!!
     
  12. rarz macrumors newbie

    Joined:
    Sep 13, 2010
    #12
    Hi marshaul,
    Thanks man, but I'm not sure if we have the same problem. How do you put it in sleep mode if it won't boot?




    This model works well on mac, but if you can avoid buying a zwf* you probably will have less headaches. Older XFX models seems to be a cool option, but them are way hard to find around.. you should check the 4870 thread to have a better idea of which models are the best.
     
  13. johhhn macrumors newbie

    Joined:
    Mar 16, 2010
    #13
    Does this work for you at all? seems like it doesn't work in your Mac Pro-- not sure I want to buy this model :)
     
  14. rarz macrumors newbie

    Joined:
    Sep 13, 2010
    #14
    It worked with a previous flashing, but I wanted to improve it changing fan settings. Then I flashed again few more times until I ended bricking it. My fault, probably.

    I've read other people having this card working. But again, I do believe older versions are better to flash.
     
  15. johhhn macrumors newbie

    Joined:
    Mar 16, 2010
    #15
    Thanks,, that makes more sense to me.

    What card are you using now?

    And does anyone have a fanless video card for 1st get Mac Pro that is 100% working and willing to sell?

    -- btw-- I'm going to be selling a 1900xt flashed WITH upgraded fan, works flawlessly. I'm currently running a 3870, which I will sell, once I upgrade to a 4870.
     
  16. marshaul macrumors newbie

    Joined:
    Oct 10, 2010
    #16
    Well, you weren't specific as to exactly how it fails to boot, other than a black screen.

    What happened to me is, after flashing the card, I would get the grey screen and apple logo for a few seconds, then a black screen and apparently nothing.

    My initial thought was that the computer wasn't booting. But, it was booting all the way to the login window, where I discovered that it will display after waking from sleep.

    Anyway, this probably isn't your problem, if you can't use the card to boot into any OS. If the card won't boot any OS, the firmware is probably bad. Maybe it is bricked.





    As for my experience, I just flashed an E.0 and a G.1. Both caused the same issue with my Mac Pro 1,1 (no display on boot until sleeping and waking), but the G.1 didn't display this issue on my friend's Mac Pro (I believe his is a 1,3).

    Other than this issue, the card runs well. I haven't done any benchmarking or heavy gaming, and I probably won't for the time being.

    As for heat, mine idles at about 64°C. I might play with the fan speed a little, but if I do I doubt I'll flash it more than one or two more times.
     
  17. vivniko thread starter macrumors newbie

    Joined:
    Jun 6, 2007
    #17
    Graphics Card Flashing Progress – Latest Update

    I've finally had a chance to fiddle around with my graphics card some more. School got in the way for the past few months.
    Still no luck with getting the graphics card to work smoothly.

    The issue I had is that my entire screen was blank.
    How do I figure out which version my graphics card is?

    I tried installing Keita 1's patch, and I installed it twice as recommended. The first time I installed it the computer booted practically normal, but even just dragging my cursor through the dock the icons were a little choppy (which they normally aren't, even with my weaker GeForce 7300 GT card).

    Installing the patch a second time created some interesting results. Now whenever I try to boot with the 4870 plugged into my monitor, once the computer boot gets to the traditional light-blue screen part, it gets stuck. It will quickly flash an even lighter blue every 5 seconds or so. I have an installation of Leopard 10.5.8 and the card still boots decently (but not running at full capacity) into that.

    My Mac Pro is by now running 10.6.7 on my main Snow Leopard installation. The name of Keita 1's driver suggests that it is for 10.6.4... could the fact I am running a newer version of the OS be part of the problem?

    I tried your modified ROM you posted here, audio_inside, and that had the same result as the ROMs I've previously tried.

    Most recently I tried the flashing method from this website. Before I tried this method, I first flashed my card with it's factory default ROM to reset it. When I got to the point where I flashed the card, I noticed that some of my information (Old/New SSID, P/N, and BIOS Version) did not match up. In the guide they appear the same:

    [​IMG]

    The information when I flashed the card is as follows:

    Old SSID: 2448
    New SSID: 2441
    Old P/N: 113-HD487AZWF92_113_BA4101-005
    New P/N: 113-BA0706-101
    Old DeviceID: 9440
    New Device ID: 9440
    Old Product Name: Wekiva RV770 B94101 Board
    New Product Name: Wekiva RV770 B50706 Board
    Old BIOS Version: 011.022.003.007.032946
    New BIOS Version: 011.013.000.001.030513
    Flash type: SST25VF010
    20000/20000h bytes programmed
    20000/20000h bytes verified

    I'm not entirely certain what these codes/numbers mean, but could this be part of the problem why my graphics card flashing is not entirely succeeding?


    Currently I'm not concerned with getting my graphics card to work perfectly in OSX (although that would be nice). I have Vista installed with Boot Camp on my Mac Pro, and I can't get the graphics card to work there either. When I try booting the computer to Vista with the monitor plugged into the 4870, I get the following error:

    YOU HAVE NOT CONNECTED ONE OF YOUR VIDEO CARD POWER CONNECTORS TO THE POWER SUPPLY. PLEASE REFER TO THE 'GETTING STARTED GUIDE' FOR PROPER HARDWARE INSTALLATION

    Does anyone have any idea on how to fix or bypass this? I've double-checked and the power cables are plugged in properly to the graphics card, and the Expansion Slot Utility claims that it has full power in OSX.

    If anyone has any suggestions on what I can do to at least get the graphics card work in Windows on my Mac Pro, I'd greatly appreciate it. It'd be even better if I can get it to work properly in OSX, but it's not too important. Thanks!
     
  18. Cindori macrumors 68040

    Cindori

    Joined:
    Jan 17, 2008
    Location:
    Sweden
    #18
    You cant patch new OS with old patches.


    keita has a new pkg. go find it
     
  19. gullySn0wCat macrumors 6502

    Joined:
    Dec 7, 2010
    #19
    About the sleep problem: I know how to fix it on a Hackintosh, you just need to tell Chameleon the correct resolution for your monitor (the resolution it expects being different from the *actual* resolution is what causes this problem.)
     

Share This Page