Flight sim displays upside down

Discussion in 'Windows, Linux & Others on the Mac' started by Batavus, Dec 13, 2009.

  1. Batavus macrumors newbie

    Dec 13, 2009
    I installed Il2 Sturmovik 'Forgotten battles' and "Pacific Fighters' on my iMac running XP. Both games run but the monitor display is upside down. Rotated 180 degrees, not flipped.

    Just before the game starts up I see the windows desktop go upside down. On quit the display and the desktop are restored to the right orientation.

    I've looked on the internet. Others are having this problem, but the fix is always for Intel Extreme Graphics: turn of the rotation option. My mac/pc has a Radeon X1600 so this fix doesn't apply to my machine. I think.

    Any ideas? TIA
  2. RSignals macrumors newbie

    May 5, 2009
    Flight sim displays upside down

    Hi ,
    I read your thread with interest, as i've also got IL46. I had it installed on my MBP and uMB under BC/XP without any trouble.
    But since i've got my new iMac 21,5" i've had a lot of trouble getting it to run (no sound, light dimmer doesn't respond, erratic mouse movement etc.). I've gotten the sound to work now, but now as soon as IL46 runs, the mouse doesn't respond. Still working on it...

    I know this doesn't help you with your particular problem (display upside down), but wanted to let you know that other folks are also having problems with IL46.

    Good luck and Cheers+
  3. wrldwzrd89 macrumors G5


    Jun 6, 2003
    Solon, OH
    The fix should still be the same, you just have to go into the ATI control panel on the Windows side and turn off that rotation option.
  4. Batavus thread starter macrumors newbie

    Dec 13, 2009

    I tried to install the Ati Catalyst control center with X1600 installers from the AMD site, but that didn't work. I then uninstalled all the drivers. After a restart the screen resolution was very coarse but that was fixed later.

    Then I went to this page:

    and downloaded the Bootcamp XP driver and control center. That worked. When I clicked on the desktop I had an ATI Catalyst option. But drat, I got a message saying I needed to install .net. I tried Pacific Fighters anyway and Bingo! the game was right side up.

    Thx, wrldwzrd89. I wasn't aware that you can install separate software for a video card. Mac folks never have to do such things (-:

    Now it's off to the Solomons for me. Tally ho!

Share This Page