Focusrite Saffire Pro + Bootcamp + XP = Unstable

Discussion in 'Digital Audio' started by matthewjumps, Dec 30, 2007.

  1. matthewjumps macrumors newbie

    Joined:
    Dec 25, 2007
    #1
    Unfortunately, my new macbook pro (2.2GHz Core 2 Duo, 2GB RAM, Texas Instruments Firewire), running Bootcamp 2.0 (which came with OSX Leopard), Windows XP SP2 with as many updates as i can get my hands on - coupled with a FocusRite Saffire Pro 26IO Firewire audio interface (running the latest drivers and firmware) - runs like crap to say the least.

    In order to get the Saffire Pro to even be recognised properly I had to use this patch and edit the registry as detailed by microsoft here http://support.microsoft.com/kb/885222

    Ive checked for IRQ conflicts (its all fine), disabled the 1394 network connection, installed Notebook Hardware Control and made sure the CPU is at max performance all the time, and messed will all kinds of other bits and pieces - to no avail

    I use FL Studio 7XXL - and projects that only consume %5-10 CPU cause pops and crackles, roughly every 5 or so seconds. Hell, even projects that consumse less CPU than that pop and crackle. On top of that, usually within an hour of turning on the interface, it will die in a really odd way - the saffire control panel will report it as plugged in and ready, FL studio will report it as good to go, and even display sound being output to the master channel, and CPU will be normal BUT no sound will come out of my speakers...

    I know its not a hardware issue because (a. the Texas Instruments Firewire card in my macbook is good quality and (b. more to the point, garageband on OSX leopard runs like a dream, not a single pop or crackle, and definately no dying....

    Does anyone have any experience with this? Im really quite frustrated :(
     
  2. rickrukkus macrumors newbie

    Joined:
    Apr 5, 2010
    #2
    yeah i am having a problem kinda like that except when i run fl 9 and just the metronome (not even running a project) i don't hear anything and its real slow. I have the asio saffire pro 24 device selected. when i select the asio4 all device (which pretty much looks at saffire) the sound is still not there and is slow still. When i select just the saffire device (not asio) still no sound. and i can see the computer tweaking out on most settings, I have just the hour glass as a pointer device when under the saffire asio setting, and the computer is the slowest at this setting. I've even done the sp2 hotfix for the firewire, updated bootcamp on the mac side and the windows side. What could be next...ive done it all! should i up the speed even more. i have it set to 2 (good for the 400 port). I could be doing somthing wrong please let me know if anyone reads this please. Thanks
     

Share This Page