Folder Actions Not working??

Discussion in 'macOS' started by GimmeSlack12, Sep 16, 2008.

  1. GimmeSlack12 macrumors 603

    GimmeSlack12

    Joined:
    Apr 29, 2005
    Location:
    San Francisco
    #1
    I have never had much luck with FolderActions. Can anyone shed some light on this for me. Here's what I want FolderActions to do for me:

    Run this script:
    Code:
    set testString to "find ~/Dropbox \\( -type f -name \"*.torrent\" \\) -exec cp {} ~/Movie\\ Torrents \\;"
    do shell script testString 
    Now I attach this to my Dropbox folder so that when I put a torrent in the folder it gets copied to my Movie Torrents folder where I have Transmission waiting to begin a new torrent. The only thing is, when I change this folder nothing happens. In fact, I've never gotten FolderActions to work consistently. I even tried adding an "delay 5" to the beginning of the script to make sure the file had copied entirely. Anyone?
     
  2. plinden macrumors 68040

    plinden

    Joined:
    Apr 8, 2004
    #2
    Not at my Mac so can't check, but I don't think the brackets are valid, are they? At least, I've never used brackets in similar commands.

    In Linux this works directly from the command line:
    find ~/Dropbox -type f -name "*.torrent" -exec cp {} ~/Movie\ Torrents \;

    but this returns an error:
    find ~/Dropbox ( -type f -name "*.torrent" ) -exec cp {} ~/Movie\ Torrents \;

    Try each of these directly in Terminal first ... see if they work in OS X.

    Edit: Was able to ssh into my Mac at home - for some reason it hasn't gone to sleep. The second command returns the same error as in Linux.
     

Share This Page