Folder and File in Trash can't be deleted

Halcyon

macrumors 6502
Original poster
Sep 21, 2006
335
0
After doing some spring cleaning I ended with a file within a folder in the trash that can't be deleted. I've tried about everything I can think to get rid of it. Restarted computer, used some file utilities to "investigate" what this file was all about, etc. I can't change the file's name, move it out of the folder or do anything with it.

The folder's name is "Legal" and the file within is "Tiếng Việt.html".

Any suggestions on getting rid of this corrupted file?

TIA

PD - I doesn't affect the proper functioning of the machine or any software, it's just bothersome to have them there and not being able to get rid of them.
 

angelwatt

Moderator emeritus
Aug 16, 2005
7,857
7
USA
You can try deleting it from Terminal (command line). Just go to the trash can: cd ~/.Trash then delete the files rm *.* Then you may need to hit y to confirm.
 

Halcyon

macrumors 6502
Original poster
Sep 21, 2006
335
0
Problem solved

Thanks Angelwatt, but already tried that and it did not work.

Found an older thread on the same precise subject and solved the problem. It seems that this file is a pesky one because it was the same exact file (same name at least) that many other users had problems getting rid of it.

It seems this file belongs to Adobe's CS2 suit and if you don't properly unisntall it when upgrading, or for whatever reason, this pesky file is not deleted. Funny thing is I upgraded to CS3 weeks ago and have not deleted my CS2 Photoshop and Illustrator yet...go figure!

Proceedure:
1.- Restart in Safe Mode (press shift while restarting).
2.- While booted in Safe Mode drag folder and file to trash and delete.
3.- Restart like you normally do.

That's all folks :)
 

celine

macrumors newbie
Apr 17, 2008
1
0
After doing some spring cleaning I ended with a file within a folder in the trash that can't be deleted. I've tried about everything I can think to get rid of it. Restarted computer, used some file utilities to "investigate" what this file was all about, etc. I can't change the file's name, move it out of the folder or do anything with it.

The folder's name is "Legal" and the file within is "Tiếng Việt.html".

Any suggestions on getting rid of this corrupted file?

TIA

PD - I doesn't affect the proper functioning of the machine or any software, it's just bothersome to have them there and not being able to get rid of them.
I have the exact same problem, with the exact same file-name! i hope your method will work.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.