Folder/File Name "Truncation"

Discussion in 'macOS' started by Guzaking, Mar 30, 2015.

  1. Guzaking macrumors member

    Joined:
    Mar 4, 2015
    #1
    I have been trying to find a solution for a very very long time on how to have the longer names of my folders and files to drop down to a 2nd line when viewing in the grid view in the My Finder window.

    In Leopard 10.5 by default you are able to see long folder/file names drop down to a 2nd line, but I can't find a setting to replicate this action in any other OSX after that one. It makes it harder to see a folder/file name when it is truncated.

    So as an example; Williams Grand Prix Engineering Limited looks like Williams...ted as a folder title and I would much rather prefer to have it look like the old style;

    Williams Grand Prix
    Engineering Limited

    Is there a setting somewhere or a terminal command in Snow Leopard where I can make this change? I have tried to explain to Apple Care multiple times, but they were stupid enough to not even know what truncate meant after I explained it thoroughly.

    Also, please do not suggest the use of just the other List views in My Finder, my inquiry is for the Grid view only as this is the only view which I use.
     
  2. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #2
    In Mavericks, it does wrap to two lines in Grid view, but not longer.
    No, there isn't.
    That's because it's not truncating. It's simply failing to wrap the way you want. The issue is with wrapping, not truncating.
    You're not going to change the way Finder works. To eliminate a solution because it involves a view that you don't use is illogical. The List view is much more reliable than the Grid view, which doesn't always display all contents of folders.
     
  3. grahamperrin macrumors 601

    grahamperrin

    Joined:
    Jun 8, 2007
    #3
    com.apple.Finder MaximumLabelLines

    In Terminal, please run the following command. If the output is a value, what's the number?

    defaults read com.apple.Finder MaximumLabelLines
     
  4. Guzaking thread starter macrumors member

    Joined:
    Mar 4, 2015
    #4
    I use Mavericks on one of my partitions and it does not show the title being dropped down to the 2nd line in Grid view. I've used all OSX versions since Leopard 10.5 and none of the latter versions have this 2 line display in the My Finder Window, (maybe on the Desktop only, but that is insignificant).

    Why would List view be more reliable...more reliable than what, I don't think there is a failure issue using different views, its merely a preference issue to the user which i think Grid view is much better or atleast for my purposes.

    I will try this command prompt in Terminal suggested by Graham and update later.
     
  5. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #5
    There's something wrong with your particular installation, because it certainly shows 2 lines in Mavericks:
    Screen Shot 2015-03-30 at 6.41.31 PM.PNG
    What you're calling Grid view (actually Icon view) frequently does not display all items in a folder because some are outside the boundary of the window. You have to click "Clean Up" to make them appear, and it doesn't remember that setting.
     
  6. Guzaking thread starter macrumors member

    Joined:
    Mar 4, 2015
    #6
    I did this but the terminal response was command not found. Is there a way to change or specify a character count per line or something or maximum number of characters to display?

    GG...I'm not sure how or why the "wrapping" works for you in Mavericks, but it would never show for me. I've been using ML lately but reverting back to SL and trying to set that SL up now. I saw this double line drop down in Leopard, so I'm guessing that there has to be a way to make it work for Snow Leopard yes?
     
  7. grahamperrin macrumors 601

    grahamperrin

    Joined:
    Jun 8, 2007
    #7
    That seems peculiar. What exactly were the words?

    This command:

    defaults write com.apple.finder MaximumLabelLines -int 3

    – then restart Finder, or log out.

    If Finder in Snow Leopard uses the MaximumLabelLines key, then setting its value to 3 might have the desired effect. If that key is not used in Snow Leopard, its presence should do no harm.
     
  8. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #8
    Even with that value set to 3, Finder still only displays 2 lines in Mavericks.
     
  9. grahamperrin macrumors 601

    grahamperrin

    Joined:
    Jun 8, 2007
    #9
    Snow Leopard

    Try this (a different key for the value of 3) –

    defaults write com.apple.finder FXMaximumLabelLines -int 3

    – then again log out, or relaunch Finder.

    References:

    Mavericks

    Interesting, thanks.

    With both MaximumLabelLines and FXMaximumLabelLines set to 3, Finder will sometimes show no more than one line; this is exemplified in the fourth attachment to this post. Realistically I would never prefer that view so I treat this as a minor bug.

    The fifth attachment shows that whilst display of the name (in the content area) may be limited to two lines, in the frame of the window you can view the full name in the path bar, and the path in the title bar.
     

    Attached Files:

  10. Guzaking thread starter macrumors member

    Joined:
    Mar 4, 2015
    #10
    its good to see some more activity on this topic as it is a good remedy for me or anyone else that wants to customize that Grid Icon View :)

    I did this and the response was The domain/default pair of (com.apple.Finder, MaximumLabelLines) does not exist

    I just copied and pasted your exact line into command so there was no issue of wrong pronunciation or mis-spells even though Terminal put its own comma after the Finder word in its response.

    putting in defaults write com.apple.finder MaximumLabelLines -int 3 there was no Terminal response besides just my computer name and MacBook Pro I can't quit Finder it doesn't give me that option it seems so now I will log off and see if the change has taken affect.
     
  11. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #11
    You can restart Finder by holding down the Option/Alt key, then right-click the Finder icon in your Dock. You will see Relaunch as an option.
    Screen Shot 2015-04-01 at 4.50.22 PM.PNG
    Alternatively, you can use Command-Option-Esc to bring up the Force Quit menu, then select Finder and then Relaunch.
    Screen Shot 2015-04-01 at 4.51.11 PM.PNG
    Or, you could do this:
    Screen Shot 2015-04-01 at 4.48.37 PM.PNG
     
  12. Guzaking thread starter macrumors member

    Joined:
    Mar 4, 2015
    #12
    Some options show up on some OSX's while it doesn't on others, Snow Leopard didn't have them available as per some snapshots, but I didn't think about the Force Quit Applications window which it was there and can be used.

    Regardless, the 2nd option try of defaults write com.apple.finder MaximumLabelLines -int 3 didn't work either after a log out and a shut down so I will try Graham's 3rd line with the FX and report back. I hope it works.
     

    Attached Files:

  13. GGJstudios, Apr 1, 2015
    Last edited: Apr 1, 2015

    GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #13
    All those options for relaunching Finder have been available on every OS X version since Leopard and even earlier (as far back as 2004). To relaunch from the Dock, press and hold the Option key before you right-click the Finder icon. To add the "Quit Finder" item to your Finder menu, enter the following command in Terminal, then relaunch Finder:

    defaults write com.apple.finder QuitMenuItem -boolean​
     
  14. Guzaking, Apr 1, 2015
    Last edited: Apr 1, 2015

    Guzaking thread starter macrumors member

    Joined:
    Mar 4, 2015
    #14
    hmm... I'm not sure why I don't have it, this is a new fresh SL install just a few days ago using the original Apple install discs of 10.6.6 that came with the MBP, that's odd.

    well I just tried the 3rd "FX" option and 3 times was not the charm unfortunately :confused: you are seeing it in Mav's GG from your snapshots, what are you Graham using for an OSX?

    Anybody else out there have any more ideas or could chime in with other suggestions? There has got to be a fix out there somewhere for this...I hope.
     
  15. grahamperrin macrumors 601

    grahamperrin

    Joined:
    Jun 8, 2007
    #15
    Mavericks.
     
  16. Guzaking thread starter macrumors member

    Joined:
    Mar 4, 2015
    #16
    maybe these terminal codes are only working for Mavericks if you and GG are seeing them with no problems, so would there be a different line code for other OSX versions or would/should it all be the same for all of them?

    Maybe seeing what the line code is in Leopard may help to duplicate it to Snow Leopard...I don't know? I'm just throwin' out ideas I guess...
     
  17. grahamperrin macrumors 601

    grahamperrin

    Joined:
    Jun 8, 2007
    #17
    See above. The defaults can be written, with a value of 3 for the key, but I can't find any way of using Finder that uses more than 2 lines.
     
  18. Guzaking thread starter macrumors member

    Joined:
    Mar 4, 2015
    #18
    well I'll take any more lines than only 1 but the default codes you've given me aren't giving me anymore lines than the default 1 line that it is on now.

    If it would work to give me 2 lines great, if it could give me 3 lines even better, but so far all I'm getting is the error messages I copied and pasted in my responses above. It does not seem to work for Snow Leopard unless the code needs to be different?...any other code line suggestions?
     
  19. grahamperrin macrumors 601

    grahamperrin

    Joined:
    Jun 8, 2007
    #19
    Please note, that's not an error. It means that for what the defaults command tried to read, no preference was set.

    A write should succeed. Please see the two references in the Snow Leopard part of my earlier post. So, you can try:

    Code:
    defaults write com.apple.finder FXMaximumLabelLines -int 2
    or

    Code:
    defaults write com.apple.finder FXMaximumLabelLines -int 3
    – then relaunch Finder.
     
  20. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #20
    It won't do any good. Even with the value set to 3, Finder still shows a maximum of 2 lines.
     
  21. grahamperrin macrumors 601

    grahamperrin

    Joined:
    Jun 8, 2007
    #21
    Does that limitation affect Snow Leopard, Lion and Mountain Lion?

    I can't recall which version of the operating system introduced, to Finder, the option to 'Show item info'.
     
  22. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #22
    I can't vouch for Lion and ML, since I skipped them both and went directly from Snow Leopard to Mavericks, but it does apply to SL, as well.
     
  23. Guzaking thread starter macrumors member

    Joined:
    Mar 4, 2015
    #23
    these commands have successfully changed the 2 line display for folders / files on the desktop only, and it did that the first time around when I used them a few days ago, but it still hasn't and can't change the folders / files view in the My Finder Window for Snow Leopard. There has to be another code or something missing in that code line that would apply to the My Finder Window specifically...possibly...hopefully? lol
     
  24. Guzaking thread starter macrumors member

    Joined:
    Mar 4, 2015
    #24
    Still hoping that someone can come up with a successful change in Snow Leopard for this problem. No changes took affect in the My Finder Window for the Icon View yet. Any other suggestions?
     

Share This Page