Folder greyed out, cannot access

naryn

macrumors newbie
Original poster
Jan 23, 2009
16
0
Hi, I need some help. I was copying some data to my server and there was a network failure. The half copied folder is now grey in the finder and i cannot open it or see the contents. It has files inside, i can browse them at the command line, i can even move the folder between volumes but i cant un-grey it and i cant drill down into it.

I cannot find an answer to this on google so if someone can tell me how to fix it please that would be great.

naryn
 

DewGuy1999

macrumors 68040
Jan 25, 2009
3,193
6
This may sound like a "duh" question, but have you reconnected to the network?
 

Strommen

macrumors newbie
Sep 17, 2010
1
0
im having the exact same problem. was copying files to a media server and got disconnected from the network halfway through. for my flatmates who all use windows it works like normal: they can see the folder and its contents. but for me the folder is greyed out and i cant access it.

really really annoying, and i have no idea what causes it or how to fix it.
 

MacForScience

macrumors 6502
Sep 7, 2010
481
5
USA
Hi, I need some help. I was copying some data to my server and there was a network failure. The half copied folder is now grey in the finder and i cannot open it or see the contents. It has files inside, i can browse them at the command line, i can even move the folder between volumes but i cant un-grey it and i cant drill down into it.

I cannot find an answer to this on google so if someone can tell me how to fix it please that would be great.

naryn
Have you deleted the half-copied part on the client side? Have you restarted?

Cheers
 

boz0

macrumors regular
May 21, 2007
166
1
/dev/null
From the terminal, rename your folder :

Code:
# mv MyFolder TempFolder
Then make a new one and move all the files inside :

Code:
# mkdir MyFolder
# mv TempFolder/* MyFolder
 
  • Like
Reactions: dtruong

digitalhen

macrumors regular
Jan 10, 2006
219
64
From the terminal, rename your folder :

Code:
# mv MyFolder TempFolder
Then make a new one and move all the files inside :

Code:
# mkdir MyFolder
# mv TempFolder/* MyFolder
Very handy tip! Thanks
 

reycat

macrumors member
Jun 24, 2009
97
43
From the terminal, rename your folder :

Code:
# mv MyFolder TempFolder
Then make a new one and move all the files inside :

Code:
# mkdir MyFolder
# mv TempFolder/* MyFolder
Thank you very much. I had the same problem and this fixed it.
 

steve77uk

macrumors regular
Oct 28, 2007
111
6
UK
Thanks

This tip has just saved me another 11 hours worth of copying after mine failed 90% of the way through!

Thank you!!
 

mandusberg

macrumors newbie
Oct 8, 2012
1
0
Sweden
Duplicate Folder.

Hi there!

I solved the same problem this way:

Right click on the greyed folder and select: Duplicate Folder.

Wait until it's done, and that should be it!

/Mandus
 

rhoydotp

macrumors 6502
Sep 28, 2006
467
74
Code:
# mv TempFolder/* MyFolder
first off, i know that this has helped resolve the issue.

but, coming from a long-time unix admin, i would not recommend doing this especially if you have tons of files/folders/subfolders. if for some reason, the 'mv' gets cancelled or gets hung, you'll end up with two folders (or sub-folders) that have incomplete data. i'd recommend doing a straight copy or 'tar. it is better in preserving permissions, handling special characters and links.


Code:
# cp -pR TempFolder/* MyFolder/
or

Code:
# (cd TempFolder; tar cf - . ) | ( cd MyFolder; tar xpf - )
just a better solution, a little complicated but believe me, it will save you from cleaning up the mess that 'mv' will leave you if it fails somewhere between the start and end :D

Right click on the greyed folder and select: Duplicate Folder.
of course, there is the easy way, too! :)
 

aquaticmatt

macrumors newbie
Feb 3, 2013
1
2
The reason for this symptom is often that the creation date of the folder is incorrectly set after such a failure resulting in the greyed out folder.

Set the folder creation date correctly using the SetFile terminal command and everything will be fine (no need to copy/duplicate/...)

e.g:
SetFile -d 02/02/2013 <folder_path>

regards
matthieu
 

Love The Mac

macrumors newbie
Feb 25, 2013
1
0
The reason for this symptom is often that the creation date of the folder is incorrectly set after such a failure resulting in the greyed out folder.

Set the folder creation date correctly using the SetFile terminal command and everything will be fine (no need to copy/duplicate/...)

e.g:
SetFile -d 02/02/2013 <folder_path>

regards
matthieu
Bash reports that there's no such command as SetFile - is there a command that will do this? I've used a free utility called Miana, available from the App Store which did instantly make the directory accessible again, but I would prefer to use a terminal command as you're suggesting if there is one. Thanks for a solution which is so quick to implement.
 

hunter3740

macrumors member
Aug 28, 2008
45
0
Pittsburgh, PA
change create or modify times

Bash reports that there's no such command as SetFile - is there a command that will do this?
touch -m -t yymmddhhmm path
(e.g. touch -m -t 1208171131 /Volumes/share/folder or "man touch" for more info)

But this didn't help me. Copying/duplicating anyway you desire did work. This happened to me because a machine turned off in the middle of a file transfer.
 

MacMe66

macrumors newbie
May 21, 2007
3
0
another solution

i just spent a wile trying above methods with no success. maybe its the hangover, lol. Anyway i found this extremely simple solution: searching for a file name inside the grayed out folder returned .. the files location. So i rightclicked it to "open enclosing folder". Got all the files listed and moved it to a new folder.. problem solved :)
 

cyglenn

macrumors newbie
Mar 25, 2013
1
0
copying bad hard drive

I had a bad hard drive from an iMac connecting using a hard drive dock. I was trying to backup some important files but I had to wait for the drive to cool off before coping any files off of it (putting it in a freezer helps). It would get about 75% through and stop responding. It left a grayed out folder that I wasn't able to access before it completely gave out.

I did what Mandus suggested and right clicked on the grayed out folder and selected duplicate. I was then able to access enough of the files to retrieve the users important documents.

thanks
 

ehm2007

macrumors newbie
Mar 27, 2013
1
0
just found another solution

I was having the same trouble on Mountain Lion with a greyed out folder from a Finder crash while copying to an external drive, and I fixed it by creating an alias of the greyed folder. The alias allowed me to see all of the files inside, so I then just moved them to a new folder.
 

petehumble

macrumors member
Sep 12, 2010
30
0
Thanks!!

i just spent a wile trying above methods with no success. maybe its the hangover, lol. Anyway i found this extremely simple solution: searching for a file name inside the grayed out folder returned .. the files location. So i rightclicked it to "open enclosing folder". Got all the files listed and moved it to a new folder.. problem solved :)
Best, simplest & quickest. Great solution. Thanks
 

wcasado

macrumors newbie
Aug 29, 2013
1
0
Great way to fix this.

i just spent a wile trying above methods with no success. maybe its the hangover, lol. Anyway i found this extremely simple solution: searching for a file name inside the grayed out folder returned .. the files location. So i rightclicked it to "open enclosing folder". Got all the files listed and moved it to a new folder.. problem solved :)
It just did it for me. Thank you you guys are the best!!!
 

Smallsmalls

macrumors newbie
Nov 5, 2013
1
0
Wot i did -

Hi, I tried all of these suggestions and none seemed to work. Maybe 10.9 is a bit different since these were posted?

Anyway, I found that I could access the files in a greyed out folder if I navigate to and highlight the folder in column view and then switch to icon view. From there it's super quick to copy the files to a new folder on the same disk.
 

danroberto

macrumors newbie
Oct 16, 2008
1
0
i just spent a wile trying above methods with no success. maybe its the hangover, lol. Anyway i found this extremely simple solution: searching for a file name inside the grayed out folder returned .. the files location. So i rightclicked it to "open enclosing folder". Got all the files listed and moved it to a new folder.. problem solved :)
Great solution! You saved me a lot of time. Thanks!!!
 

Ranjoharbri

macrumors newbie
Nov 19, 2012
2
0
Quick Fix Using Adobe Lightroom 5

I had a similar problem with a greyed out folder after attempting to transfer 450Gb of photographs to a NAS.

I'm a pro photographer and use a lot of Adobe's CC software, including Lightroom 5.

I created an alias folder in the Library component and dragged and dropped all the files which were still visible in the LR.

The transfer was instantaneous, all I had to do was delete the original greyed out folder, and remove the 'Alias' file name.

If anyone is having problems with large folders containing images and don't use Adobe's software, you can download a trial version and just use it as a work around.
 

kskstudios

macrumors newbie
Mar 6, 2014
1
0
Worked for us. Thanks Mandus!

We were having trouble with greyed out folders with inaccesible contents caused by a drive mysteriously ejecting during a large file xfer.

Mandus' suggestion was the easiest solution to execute and worked perfectly for us. Thanks!

Hi there!

I solved the same problem this way:

Right click on the greyed folder and select: Duplicate Folder.

Wait until it's done, and that should be it!

/Mandus
 

k-hawinkler

macrumors member
Sep 14, 2011
89
0
From the terminal, rename your folder :

Code:
# mv MyFolder TempFolder
Then make a new one and move all the files inside :

Code:
# mkdir MyFolder
# mv TempFolder/* MyFolder

Many thanks. Works brilliantly!!

I was trying to copy almost 5 TB of data from one TB RAID to another one.
After 3.7 TB had been successfully copied I noticed that no data was being copied anymore.
So I cancelled the copy process and was left with the greyed our folder. A bummer!

Your tip saved me another long copy process.

BTW, this problem doesn't seem to happen if I copy the data with CCC.
My disks seem fine. I checked with Disk Utility, Drive Genius 3, and Scannerz.

Thanks again.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.