Folding setup, Ubuntu and X help needed

Discussion in 'Distributed Computing' started by ChristianJapan, Oct 21, 2013.

  1. ChristianJapan macrumors 601

    ChristianJapan

    Joined:
    May 10, 2010
    Location:
    日本
    #1
    I know this is a bit offtopic for Mac OSX but maybe someone here knows about Ubuntu, Nvidia setup and X.

    As my knowledge with the xorg,conf is a bit limited I wonder if you can help me to optimize my setup.
    Currently I have three GPU: 2xGTX 780 and one GTX 660Ti

    One of the 780 is the primary screen where all GUI interaction take place; slot close to CPU.
    The 660Ti is most distant to the CPU. This way is the only physical chance to setup the cards on the motherboard (Asus P8Z77 Pro). The 780s are too long for the outside slot (some jumper and connector in the way).

    Based on PPD is seems that the primary card gets a hit of 4000 to 10000 PPD which I would like to harvest too. In addition the temps are 8 degrees higher compared to the non-UI 780.

    How can I configure .nvidia-settings.rc and/or xorg.conf to make the 660TI the primary GPU dealing with UI and get both 780 fully focused on folding. I tried several things but right now I can't even start nvidia-settings in GUI mode anymore (core dumps). The 660TI is also connected via DVI to the same monitor as the primary card (monitor support two inputs); but I get only white screen on that.

    Here my current xorg.conf (I tried to play with the screen layout, thats why it seems wired with screen 0 and "screen2")

    Code:
    Section "ServerLayout"
        Identifier     "Layout0"
        Screen      0  "Screen2" 1920 0
        Screen      1  "Screen1" LeftOf "Screen2"
        Screen      2  "Screen0" RightOf "Screen2"
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Mouse0" "CorePointer"
        Option         "Xinerama" "0"
    EndSection
    
    Section "Files"
    EndSection
    
    Section "InputDevice"
    
        # generated from default
        Identifier     "Mouse0"
        Driver         "mouse"
        Option         "Protocol" "auto"
        Option         "Device" "/dev/psaux"
        Option         "Emulate3Buttons" "no"
        Option         "ZAxisMapping" "4 5"
    EndSection
    
    Section "InputDevice"
    
        # generated from default
        Identifier     "Keyboard0"
        Driver         "kbd"
    EndSection
    
    Section "Monitor"
        Identifier     "Monitor0"
        VendorName     "Unknown"
        ModelName      "Eizo SX2461W"
        HorizSync       31.0 - 76.0
        VertRefresh     59.0 - 61.0
        Option         "DPMS"
    EndSection
    
    Section "Monitor"
        Identifier     "Monitor2"
        VendorName     "Unknown"
        ModelName      "Eizo SX2461W"
        HorizSync       31.0 - 76.0
        VertRefresh     59.0 - 61.0
        Option         "DPMS"
    EndSection
    
    Section "Monitor"
        Identifier     "Monitor1"
        VendorName     "Unknown"
        ModelName      "Unknown"
        HorizSync       28.0 - 33.0
        VertRefresh     43.0 - 72.0
        Option         "DPMS"
    EndSection
    
    Section "Device"
        Identifier     "Device0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "GeForce GTX 780"
        BusID          "PCI:1:0:0"
    EndSection
    
    Section "Device"
        Identifier     "Device1"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "GeForce GTX 780"
        BusID          "PCI:2:0:0"
    EndSection
    
    Section "Device"
        Identifier     "Device2"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "GeForce GTX 660 Ti"
        BusID          "PCI:3:0:0"
    EndSection
    
    Section "Screen"
        Identifier     "Screen0"
        Device         "Device0"
        Monitor        "Monitor0"
        DefaultDepth    24
        Option         "Coolbits" "5" 
        Option         "Stereo" "0"
        Option         "metamodes" "nvidia-auto-select +0+0"
        SubSection     "Display"
            Depth       24
        EndSubSection
    EndSection
    
    Section "Screen"
        Identifier     "Screen1"
        Device         "Device1"
        Monitor        "Monitor1"
        DefaultDepth    24
        Option         "Coolbits" "5" 
        Option         "Stereo" "0"
        Option         "metamodes" "nvidia-auto-select +0+0"
        SubSection     "Display"
            Depth       24
        EndSubSection
    EndSection
    
    Section "Screen"
        Identifier     "Screen2"
        Device         "Device2"
        Monitor        "Monitor2"
        DefaultDepth    24
        Option         "Coolbits" "5" 
        Option         "Stereo" "0"
        Option         "metamodes" "nvidia-auto-select +0+0"
        SubSection     "Display"
            Depth       24
        EndSubSection
    EndSection
    
    
    and my SMI print (660TI right now not folding; thats why so cool)

    Code:
    Mon Oct 21 23:17:01 2013       
    +------------------------------------------------------+                       
    | NVIDIA-SMI 5.319.49   Driver Version: 319.49         |                       
    |-------------------------------+----------------------+----------------------+
    | GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
    | Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
    |===============================+======================+======================|
    |   0  GeForce GTX 780     Off  | 0000:01:00.0     N/A |                  N/A |
    | 70%   70C  N/A     N/A /  N/A |      132MB /  3071MB |     N/A      Default |
    +-------------------------------+----------------------+----------------------+
    |   1  GeForce GTX 780     Off  | 0000:02:00.0     N/A |                  N/A |
    | 70%   62C  N/A     N/A /  N/A |      280MB /  3071MB |     N/A      Default |
    +-------------------------------+----------------------+----------------------+
    |   2  GeForce GTX 660 Ti  Off  | 0000:03:00.0     N/A |                  N/A |
    | 30%   28C  N/A     N/A /  N/A |        8MB /  2047MB |     N/A      Default |
    +-------------------------------+----------------------+----------------------+
                                                                                   
    +-----------------------------------------------------------------------------+
    | Compute processes:                                               GPU Memory |
    |  GPU       PID  Process name                                     Usage      |
    |=============================================================================|
    |    0            Not Supported                                               |
    |    1            Not Supported                                               |
    |    2            Not Supported                                               |
    +-----------------------------------------------------------------------------+
    
    Thanks in advance to get me more PPD :)
     
  2. twoodcc macrumors P6

    twoodcc

    Joined:
    Feb 3, 2005
    Location:
    Right side of wrong
    #2
    sorry i can't help here, but hopefully someone will help you out. really hope you can get everything more efficiently going and that the driver stops crashing
     

Share This Page