font book - not showing fonts - help

Discussion in 'macOS' started by videoterrorist, Mar 11, 2008.

  1. videoterrorist macrumors newbie

    Joined:
    Aug 2, 2007
    #1
    Hi,

    I've just upgraded to Leopard & am now running 10.5.2. After doing a install from scratch I'm having problems getting fonts into font book!
    Where is the best place to put them? HD>SYSTEM>FONTS, HD>LIBRARY>FONTS, USER>LIBRARY>FONTS??
    The fonts I'm trying to use are currently in the user>library>fonts folder & I can see all of them in there, however they don't appear in Font Book at all!

    Anyone know why or where best to put them, it's driving me mad!

    Thanks in advance :)
     
  2. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #2
    Do not ever put fonts into HD>System>Fonts. That folder is reserved for use by the operating system. Put fonts into HD>Library>Fonts if you want all users of the computer to be able to use them. Otherwise, put fonts in User>Library>Fonts. If Font Book won't see your fonts, despite putting them in the correct folder(s), perhaps there's a permissions problem somewhere. For example: You don't have read permission for your own Fonts folder (which would cause Finder to ask for your password if you wanted to move stuff in there). If this is the case, do a Get Info on the offending folder, open its Ownership and Permissions section, and set things accordingly.
     
  3. videoterrorist thread starter macrumors newbie

    Joined:
    Aug 2, 2007
    #3
    Thanks for the advice, I've checked the folders & they're all set to read & write, so I don't know why the hell Font Book wont see them. I've also checked Font Book's prefs which are set to the Default install location of the user account. Is there anyway to reset FB as an app?
     
  4. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #4
    Try deleting its preferences file, which is in your user Library, inside the Preferences folder. The file's called com.apple.FontBook.plist, I believe. Relaunch Font Book. If that doesn't work, then try clearing your font caches. There are several tools that will do this for you. Keep in mind that you'll need to restart for the font cache change to take effect.
     
  5. videoterrorist thread starter macrumors newbie

    Joined:
    Aug 2, 2007
    #5
    Thanks a million for the advice!
    I ended up deleting the pref file, removing all the fonts from the folder & putting them all back in again & finally I can get on with some work! :)

    Cheers!!
     

Share This Page