Font help for dummies?

Discussion in 'Design and Graphics' started by Patiencepie, Jun 27, 2011.

  1. Patiencepie macrumors newbie

    Joined:
    Apr 8, 2011
    #1
    I have read a lot of these threads and do not understand 99 percent of the computer lingo. I have an iMac and when I open Pages and try to do something simple like make a flyer the fonts are ALL IN ONE FONT! I have used crappy public computers that show the fonts in the font that they are but not on my IMac! Please help. There must be a setting or something to make the fonts show in the fonts that they are, other wise you have to click on each and everyone to see what it looks like! It's maddening. I have taken to having a notebook next to my computer and having to hand draw the name and design of each one to go back and reference and compare, it's nuts. Please help!
     
  2. MisterMe macrumors G4

    MisterMe

    Joined:
    Jul 17, 2002
    Location:
    USA
    #2
    It sounds like your "crappy public computers" had fonts installed that you do not have on your computer. If you like those fonts, then you should record the names of the fonts that you use. Then you can install those same fonts on your computer.

    An easy way to record the fonts used in the document is to create a PDF version of it. Adobe Reader will give you the names of all fonts embedded in the PDF.
     
  3. NXTMIKE, Jun 27, 2011
    Last edited: Jun 27, 2011

    NXTMIKE macrumors 6502

    Joined:
    Nov 11, 2008
    Location:
    Canada
    #3
    I never knew that such issue existed in Pages. Mine has always been normal on both my Macs (see screen shot attached).

    So correct me if I'm wrong, but as appose to my situation where each font is displayed in it's respective font, each font for you is displayed in the same typeface?
     

    Attached Files:

  4. Patiencepie thread starter macrumors newbie

    Joined:
    Apr 8, 2011
    #4
    Yes! yes! yes! this is exactly the problem! The screen shot you showed here with all of the fonts being"in the font that it is" is how Most computers are but not my iMac! And I can't figure out why. When I go to the fonts, they are all listed by name but "in" one single font so you can't "see" what the font is unless you click on it and look to the top of the section where is is displayed. So I have to "click on" each font one at a time and look at the top to see what it looks like rather than, as your screen shot shows, all the fonts in their own font! It takes forever to click on each individual one and there is no way to make comparisons.
    It's like, as an artist, having 50 or so tubes of paint, all the same color tubes, and being only able to open up and look at one color at a time, and NOT being able to put them all out on a pallet for comparison. There has to be a setting or something to fix this. Please help! Thank you for your response too!
     
  5. ezekielrage_99 macrumors 68040

    ezekielrage_99

    Joined:
    Oct 12, 2005
    #5
    For Pages...

    Command key icon (Command key) + ,

    Select Font Preview

    Done :)
     
  6. Patiencepie thread starter macrumors newbie

    Joined:
    Apr 8, 2011
    #6
    I was hoping it would be as simple as this but it did not work. I must be doing something wrong.
    I went to Pages. I pressed the Command key and the Comma key. A window came up that said"GeneralPreferences" at the top. The second section down showed "Preview" with a box next to it. Followed by the words "include preview in document by default". I checked the box and went to look at my fonts and they were still all the same typeface.
    What did I do wrong?:confused:
     
  7. ezekielrage_99 macrumors 68040

    ezekielrage_99

    Joined:
    Oct 12, 2005
    #7
    Just out of interest what type of mac are you using (CPU, RAM?) and what version of Pages are you using?
     
  8. dmz macrumors regular

    dmz

    Joined:
    Jan 29, 2007
    Location:
    Canada
    #8
    Pages Font Preview Preferences

    You should see something that looks like this in the General, i.e. first, panel of the Preferences in Pages:

    [​IMG]

    The green highlighted area is where you turn this feature off and on.

    Font Book is a much better way to get to know your fonts...

    Hope that helps...

    dmz
     
  9. dmz macrumors regular

    dmz

    Joined:
    Jan 29, 2007
    Location:
    Canada
    #9
    Pages Font Menu Preview

    I think we misunderstood your question? Are you accessing your fonts from the menu bar, i.e. Format->Font->Show Fonts? If you are then that's why you don't see the fonts - that dialog never shows the fonts. However, picking your font from the "Format Bar" does show the font in its font (?). Like this:

    [​IMG]

    Does that help?

    Cheers!

    dmz
     
  10. Patiencepie thread starter macrumors newbie

    Joined:
    Apr 8, 2011
    #10
    I do not have the "font preview" that your sample here shows in green highlight. Mine just says "preview". But I will look for Font Book too, I have never heard of that.
     
  11. ergdegdeg Moderator emeritus

    ergdegdeg

    Joined:
    Oct 13, 2007
    #11
    What version of Pages do you have? Find out by clicking on "Pages" at the top and then selecting "About Pages".

    I have Pages 08 and it doesn't have the font preview.
     
  12. Patiencepie thread starter macrumors newbie

    Joined:
    Apr 8, 2011
    #12
    I have gone to the fonts in two different ways but I am not sure what the "Format Bar" is but I will write this down and go home and look. Unfortunately I no longer have Internet at home soi have to go to town to get on this forum! Thanks for your help!
     
  13. Patiencepie thread starter macrumors newbie

    Joined:
    Apr 8, 2011
    #13
    :eek:Oh, well this answers the problem...I have 08...very sad, what do I do? Will I simply never be able to work on graphics with lettering with this computer?
    I got Adobe and it is showing the fonts all in one typeface too. If I get a Photoshop for Apple will it show fonts? Or will I never be able to "see" fonts on this computer. Can I get a new Pages for this computer to fix this issue? Thanks everybody for all the input too!
     
  14. dmz, Jul 1, 2011
    Last edited: Jul 1, 2011

    dmz macrumors regular

    dmz

    Joined:
    Jan 29, 2007
    Location:
    Canada
    #14
    Old Pages

    Yup, that's the issue - your version of Pages is too old. I'm using iLife 09, and it has the previews. I looked at an old iLife 06, and it's pretty sparse compared to my version. This is not a Mac OS X issue.

    Adobe products included in all versions of CS all show the fonts in both their actual font and in plain text - since the name for fonts like WingDings can't be read - @#$%^* - know what I mean? They also tell you what KIND of font it is, i.e. PS, TT, OTF, etc.

    Font Book is the font manager for OS X. It's in your Applications folder, and opens automatically whenever you try to open a font file. It's basic, but it does the job.

    Cheers!

    dmz
     
  15. Patiencepie thread starter macrumors newbie

    Joined:
    Apr 8, 2011
    #15
    Wow, I am glad to at least know what's going on now! I have tried Font Book and it's ok except you still have to click on each and very one and can't make comparisons. I guess I better learn to use Adobe and forget trying to make flyers and logos in an old version of Pages!!! Thanks so much to everyone for all the advise and help!
     
  16. dmz macrumors regular

    dmz

    Joined:
    Jan 29, 2007
    Location:
    Canada
    #16
    ... or just get iLife 11 - Adobe is much more expensive, and way more complicated than Pages...

    Cheers!

    dmz
     

Share This Page