Font rendering in OS 10.6

Discussion in 'Mac Basics and Help' started by TitanJeff, Sep 14, 2010.

  1. TitanJeff macrumors regular

    TitanJeff

    Joined:
    Aug 20, 2004
    #1
    I just picked up a Macbook Pro with 10.6 and notice some fonts in Firefox appear too strong or bold. I've run a search here but not getting this corrected.

    I went to system prefs and turned off font smoothing in appearance.

    I opened terminal and put in "defaults -currentHost write -g AppleFontSmoothing -int 1" but not seeing any change there either.

    I'm a noob with terminal. When I enter the above, I get nothing but a prompt again. Am I missing something? Thanks.
     
  2. mulo macrumors 68020

    mulo

    Joined:
    Aug 22, 2010
    Location:
    Behind you
    #2
    getting a new promt just means what you asked it to has been done :)
     
  3. tpg macrumors regular

    Joined:
    Mar 19, 2010
    #3
    You say that the fonts in firefox don't look right - are these the fonts in the menus, or the font in the webpages? Firefox most probably uses a font engine completely separate from OS X to render web pages, so fiddling with apple settings won't help if it's the webpages that have issues. Perhaps you could post a screenshot of the problem?
     
  4. ToastyX macrumors regular

    Joined:
    Oct 4, 2005
    #4
    You have to log out and log back in (or reboot) to make the changes take effect.
     
  5. TitanJeff thread starter macrumors regular

    TitanJeff

    Joined:
    Aug 20, 2004
    #5
    These are fonts in webpages. In Safari, it looks good. In Firefox, too bold.

    What I used to do was go to general setting in my appearance prefs and select "standard_best for CRT" and it worked perfectly.

    Here's an example of what I'm talking about:
    http://att.macrumors.com/attachment.php?attachmentid=25088&d=1118866122
     
  6. ToastyX macrumors regular

    Joined:
    Oct 4, 2005
    #6
    Disabling "Use LCD font smoothing when available" is the same as "Standard - Best for CRT", and that terminal command is the same as "Light". You have to log out and log back in or reboot for the changes to take effect.
     
  7. TitanJeff thread starter macrumors regular

    TitanJeff

    Joined:
    Aug 20, 2004
    #7
    Hmmm... did the reboot. Still getting the bolder Firefox text. I'll give it another effort. Thanks.
     

Share This Page