Font Rendering on external Screen

Discussion in 'OS X Yosemite (10.10)' started by philipp092, Jan 25, 2015.

  1. philipp092 macrumors newbie

    Oct 30, 2014
    Hi everyone,

    I still struggle with OS X on my external Monitor, DELL U2412M. I used to love it when using my old Thinkpad running Windows 8. However, OS X made my screen unpleasant to work on.

    I already tried to force the RGB Mode on the monitor, recommended at
    It improved a bit, but text is still blurry.

    I installed Windows on Parallels Desktop and did a litte comparasion on the DELL U2412M.
    (Of cource, to be able to see the difference, you have to view this on non-retina screen)
    From these screenshots you can tell windows renders fonts much cleaner. Fonts under OS X looks blurry, especially smaller ones.

    I was just wondering - does it look so blurry on EVERY external monitor? Or is it just the DELL? I am thinking of getting the Iiyama Prolite xb2779qs with 2560x1440 resoluton. May this be a solution?
  2. tinycg macrumors member

    May 8, 2009
    OSX does font smoothing more aggressively than Windows ClearType.

    OSX will attempt to anti-alias text at all levels, I'm looking into a change in Yosemite that I just noticed where they took away some of the tweaks you could make. Previously you could selectively turn the font smoothing off on smaller font sizes, meaning bigger text would look crisp and smaller text wouldnt look blurry.

    EDIT: Go to System Prefs > General and turn font smoothing off and see if thats more to your liking.

    In parallels OSX isnt handling any of the font rendering, hence why it looks a little different.

    From experience displays with glass will provide a crisper looking display because there's no coating that can interfere, though you do get glare.

    I previously had 2 Dell U2412s and next to my LED Cinema Display the Cinema Display looked noticeably crisper. I have a couple HP ZR2740w's now and the comparison is not quite as dramatic. Some of which is related to dot pitch on a higher resolution and larger monitor.
  3. leventozler macrumors 6502

    Feb 18, 2009
    Try resetting your monitor settings, and make sure the input color method is RGB.

Share This Page